Peugeot Forums banner
1 - 18 of 18 Posts

·
Registered
Joined
·
56 Posts
Discussion Starter · #1 ·
Hi all, I've had the usual abs fault for a while and haven't had the chance to remove the sensors and clean them yet so I get the abs light on after a few minutes then the braking is fine.

Anyway tonight I went out to the car and drove about 100 yards. The stop light started to flash, the handbrake warning light came on and the display said braking fault.

Without getting it on a computer can anyone give me any clues as to the problem? Braking seems to be ok but i'm a bit worried that I'll lose them if I keep driving! The only things done to the car was a wash, and I checked the fluid levels. Didn't actually wash the engine or anything like that!

So basically i have the stop light flashing all the time, abs fault and braking fault flash on the display and the red brake warning light is permanently on.

Cheers for any help...

It's a 2003, 307, 1.4 HDi 74k on it.
 

·
Registered
Joined
·
9,731 Posts
Handbrake still working ok , not stuck on? if it is you will not have tension all the way when pulling handbrake,
after driving do the back wheels feel hot?
 

·
Registered
Joined
·
56 Posts
Discussion Starter · #3 ·
The handbrake is working ok. i tried putting it on as I was driving and the display said handbrake on, so i'm fairly sure that isn't the problem now.

I used to get the abs light after about 3 minutes, I now get it as soon as I start up. I start the engine and get 3 beeps, the display says braking fault, then 1 beep and it says abs fault.
 

·
Registered
Joined
·
387 Posts
Not sure why the handbrake light comes on but I had to get one of my censors replaced & even at Peugeot it was a reasonable repair cost, around £60 for the work I think. Probably something that someone with a decent knowlage of cars could do themselves, but I don't fall into that category :D
 

·
Registered
Joined
·
196 Posts
the other light come on when abs fault comes on it goes in to what they call standed braking system (no abs) it will be one of the back wheels clean all the rust off were the sensor sit, then try it if that failed if you follow the sensor wire there is a plug,nr tank that just unclips to put new sensor on easy job about 30mins. if you feel thumping on the left front wheel then it will be the back right,and so on.
 

·
Registered
Joined
·
56 Posts
Discussion Starter · #6 ·
Hey all, thanks for your replies.

I have got it sorted. I got it on a computer and it showed no signal on the left hand rear abs sensor. I replaced that but the fault display remained, next thing to show on the diagnostics was abs pump motor fault.

At that stage I pancaked cos I knew the abs pump wasn't a cheap replacement. I came home and googled for a while and found out that there is a big fat 30 amp fuse hidden from all the other fuses in the engine bay! it had blown and was the abs pump fuse. :D A trip to halfords and £2.69 lighter and the lights all went out.

I'm a happy person tonight! All in all it cost me £28 for the sensor from peugeot and £2.69 for a fuse.

Peugeot were looking £120 supplied and fitted for the sensor, then said high hundreds for the abs pump to be replaced, not once did they suggest a fuse...:rolleyes:
 

·
Registered
Joined
·
56 Posts
Discussion Starter · #9 ·
TraceyWill said:
This is happening to me as well, So thanks for the info, not a job for me but one for my dad is it relativly easy to do?? thanks x
To change the abs sensor is fairly easy, the fuse is easier still! If you have any bother post here and I'm sure you'll be pointed in the right direction in no time :D
 

·
Registered
Joined
·
204 Posts
Just changed mine and it cured it.
Open the bonnet, and pop the lid to the fusebox on the right.

Look between the ECU and fusebox and you will see some big fuses. It's the 3rd from the left. You can get a 30A replacement from Halfords for £2.79.

Hope this helps.
 

·
Registered
Joined
·
19 Posts
Just changed mine and it cured it.
Open the bonnet, and pop the lid to the fusebox on the right.

Look between the ECU and fusebox and you will see some big fuses. It's the 3rd from the left. You can get a 30A replacement from Halfords for £2.79.

Hope this helps.
Hi
i checked the fuse as motioned in your quote above it is ok but the fault(ABS +Brake symbol couple with ON -OFF multifuctions screen) still the same . is this danger to run with car. need a help
1.6 L 16 v sw 2007
 

·
Registered
Joined
·
4 Posts
im having the same problems as u did could u please tell me where the seperate fuse is for the abs pump
yeah this would be appreciated, when I start my '03 plate 307 1.6 petrol the same thing happens, two seperate warnings; Braking Fault then ABS Fault. Any chance someone can tell me where the fuse is in the engine bay? Cheers
 
1 - 18 of 18 Posts
Top