Peugeot Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I have a "Battery Charge Fault" on my 406 Coupe (not used it for a couple of weeks). The battery was low as the revs at idle from cold where up and down, so I removed it and have charged it up. Re-fitted but still have the fault. The rear heater will not switch on, nor will the fan for the climate control come on.

Battery voltage is at 12.5V then up to 14.4V when running. Seems as if the alternator is OK?

Swapped over the two relays in the engine compartment fuse box as one of them is to tell the ECU the engine is running, but no different.

Belt is tight and alternator is spinning.

Tried to reset the ECU but this has not worked (no bong when turning on the side lights so not sure if it worked)

Any suggestion before I have to take it to a garage for diagnostics?:confused:
 

·
Moderator
Joined
·
6,567 Posts
Try wiggling key in ign had similar fault on 807 which was worn ign switch. Interior map light also would not work as well as same faults you have.

Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
Hi Gibbo,

I tried the BSI reset but this made no difference (if it worked) -

Put the driver's window down, lift the bonnet and ensure all equipment is switched off.
Ensure all doors are closed and remove key from the ignition.
Wait for 3 minutes, disconnect the vehicle battery and wait 15 seconds.
Reconnect the vehicle battery, wait a further 10 seconds (do not open doors.).
Switch on the side lights through the driver's window.
Switch on the ignition and check system's functionality.
Hold lock button on key down for 10 seconds.
Remove key open & close door test central locking system.
Start the engine and complete the system's check.

Also getting the handbrake light flash up momenterily when driving. Last time I had this was due to a faulty switch. Rear disks and pads have just been replaced.
 

·
Registered
Joined
·
15,377 Posts
What age is the coupe as early ones are very different

handbrake light could be low brake fluid

Is heater panel in darkness ?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #8
Coupe is 2000 D9, 2.2SE. Handbrake fluid level is OK.

All of the electrics work with the exception of the rear heater and the fan for the climate control.
 

·
Registered
Joined
·
15,377 Posts
On a d9 its usually the heater blower itself or the resistor is faulty but if the blower has shorted or was drawing too much current then the wiring could also be faulty.

The blower is under the glovebox and the resistor is a little further back with a green end the wires plug into check the wire contacts carefully for scorching
 
1 - 9 of 9 Posts
Top