Peugeot Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
437 Posts
Discussion Starter #1
I had a 'Battery Charge Fault' message appear on the MFD today.

It's been a while since I had any battery/alternator woes so I found my multi meter out and checked voltage and these were the results:

With ignition on only:
Battery 12.28
Alternator Large Terminal 12.28
Alternator Small Terminal 1.16

With engine running:
Battery 11.91
Alternator Large Terminal 11.88
Alternator Small Terminal 1.16

Running with no aux belt:
Battery 11.88
Alternator Large Terminal 11.87
Alternator Small Terminal 1.16

Does anyone else think that this points to a faulty alternator?

Also when I turn the engine off, the inside of the alternator carries on spinning for several seconds which I've not noticed before so not sure if it's related or not.

Cheers
Pete
 

·
Registered
Joined
·
343 Posts
I had a 'Battery Charge Fault' message appear on the MFD today.

It's been a while since I had any battery/alternator woes so I found my multi meter out and checked voltage and these were the results:

With ignition on only:
Battery 12.28
Alternator Large Terminal 12.28
Alternator Small Terminal 1.16

With engine running:
Battery 11.91
Alternator Large Terminal 11.88
Alternator Small Terminal 1.16

Running with no aux belt:
Battery 11.88
Alternator Large Terminal 11.87
Alternator Small Terminal 1.16

Does anyone else think that this points to a faulty alternator?

Also when I turn the engine off, the inside of the alternator carries on spinning for several seconds which I've not noticed before so not sure if it's related or not.

Cheers
Pete
Have you plugged it into PP2000 disagnostic?
 

·
Registered
Joined
·
437 Posts
Discussion Starter #4
Does anyone have any opinions on this one?

I'm thinking of taking the alternator to an auto elecy I use who does starters, heaters, alternators etc but that'll leave me without a car so not sure.
 

·
Registered
Joined
·
437 Posts
Discussion Starter #6
Cheers for reply. I tried spinning the alternator pulley and when i spin it slowly, the inside of the alternator spins with the pulley but if I spin it fast the inside doesn't turn at the same rate almost like the insides are trying to catch up with the pulley.

Do you know if this is normal?

Cheers
 
1 - 8 of 8 Posts
Top