Peugeot Forums banner

1 - 19 of 19 Posts

·
Registered
Joined
·
179 Posts
Discussion Starter #1
Hi
Apologies because I know there are other threads dealing with "Battery Charge Fault" but have not seen one that addresses this. I had a new battery a few weeks ago. Today I had the beep and "Battery Charging Fault" message. The ignition (battery charge) red light came on........and went off again after about 15 minutes. I stopped and restarted several times (on hills just in case) and all was fine. I've since checked the battery and charge state using my very simple indicator - both show in the good to very good range. Any thoughts, anything else I can check? Battery terminal connections were fine. As with previous posts of mine I'd be very grateful....check out my postcode HS9 5UW.
 

·
Registered
Joined
·
1,057 Posts
Bit of a long shot but check the battery to body earth conection under the driver's feet, undo it slightly 10mm spanner and re-tighten, this was the cause of our poor starting but your symptoms are different.
 

·
Moderator
Joined
·
6,303 Posts
When it happens next check if map lights work if they don't it may be a faulty ignition switch. I had a similar problem with my old 807 wiggle the key and it would clear the fault (and map lights would start working)
 

·
Registered
Joined
·
179 Posts
Discussion Starter #6
Thanks I'll try that. I'm just hoping that it doesn't happen again - but a bit worried that it might.....and it's an indicator of something serious going wrong.
 

·
Registered
Joined
·
179 Posts
Discussion Starter #7
Ten days without a problem and blow me its done it again this morning. This time I had almost come to a stop. When I restarted car 5 minutes later neither light or warning message came on but crucially when I got home and put the tester on it said battery was OK (12v) but was discharging when engine was running. Any suggestions gratefully received - I have a busy week taking tourists around HS9 this week.:mad:
 

·
Registered
Joined
·
1,424 Posts
Alternator

When running your Alternator should be pumping between 13.00 to 14.7 volt or so into the battery if lower than 12 volt you will be running your battery flat Seems this is a simple Alternator not pumping enough Volts to me
 

·
Registered
Joined
·
179 Posts
Discussion Starter #9
Hi Jagn thanks for that. I thought alternator too but cant figure why ignition light/ battery charge fault message come on they go off again?
 

·
Registered
Joined
·
1,424 Posts
warning lights

Hi Jagn thanks for that. I thought alternator too but cant figure why ignition light/ battery charge fault message come on they go off again?
Perhaps the warning lights go off when Alternator is pumping 11.5 volts perhaps its an intermittent lack of charging I would turn the blower on full and all the lights on then check the alternator under a full load ,, The bad earth As previously posted is a possibility Also Not sure where the engine earths to the body but that could be problematic as well Any make of car suffers these sort of Earthing and electrical faults and the Intermittent ones are the worst to sort
 

·
Registered
Joined
·
134 Posts
I had an alternator problem on my old Pajero, it wasn't charging properly. But the charge light didn't show while engine was running, though did show with ignition turned on before starting. New alternator and all was good
 

·
Registered
Joined
·
179 Posts
Discussion Starter #12
Just driven round the island on a mock tour stopping and starting a dozen times....battery warning message and battery light came on .......and went off again about 6 times but battery state is worse now i.e. reading below 12 v and not changing at all when engine running? I've checked all leads, connections and earths and they seem fine.
 

·
Registered
Joined
·
1,424 Posts
handy with spanners

Just driven round the island on a mock tour stopping and starting a dozen times....battery warning message and battery light came on .......and went off again about 6 times but battery state is worse now i.e. reading below 12 v and not changing at all when engine running? I've checked all leads, connections and earths and they seem fine.

Are you handy with Spanners Looks like an Alternator change is on the cards Our Local Motor factors is good for info like that have you a Motor factor handy to give a second opinion may be they can source a Remanufactured Alternator on an exchange basis
 

·
Registered
Joined
·
179 Posts
Discussion Starter #14
Hi Jagn
I've just been looking to get an alternator ......no local motor factors so I've been looking on ebay. There are 1/2 mechanics on the island but they are always very busy but if I could get one I could probably sort it myself - I always used to back in the day when I had old cars and they broke all the time! More recently I've not had a problem or needed to touch a spanner .....until I bought this 807 which has been nothing but trouble for the last year. Anybody any suggestions on sourcing an alternator via the intermewebbymebob
 

·
Registered
Joined
·
1,424 Posts
Ebay

Hi Jagn
I've just been looking to get an alternator ......no local motor factors so I've been looking on ebay. There are 1/2 mechanics on the island but they are always very busy but if I could get one I could probably sort it myself - I always used to back in the day when I had old cars and they broke all the time! More recently I've not had a problem or needed to touch a spanner .....until I bought this 807 which has been nothing but trouble for the last year. Anybody any suggestions on sourcing an alternator via the intermewebbymebob
google 807 Alternator and it comes up with Ebay top of page so at a guess check prices there you say Island which Island is that you live on Wight,Man,Canvey ? LOL
 

·
Registered
Joined
·
179 Posts
Discussion Starter #16
I just searched Euro Car Parts and they show two - Bosch £180 and another brand £150. Not sure I want to risk or spend that much on a car I want rid of? I live on the Isle of Barra @HS9 5UW ,, beautiful but remote - 5 hours from the mainland by ferry! At times like this I wish I didnt.
 

·
Registered
Joined
·
1 Posts
hey everyone i had recently replaced alternator on my 308 t7 wagon (2010) battery warning cames on randomly sometimes when i start sometimes during hours of driving battery has been tested and shows works fine any ideas or suggestions please
 
1 - 19 of 19 Posts
Top