Peugeot Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
42 Posts
Discussion Starter #1
Hi Guys and Gals, MERRY CHRISTMAS before I start.

My partner tepee 58 plate keeps coming up with an anti polution warning and the car goes into like a limp home mode, it lacks power and its a pain on hills etc. It came and went after a service then it came back so I put it in the garage and
they noticed that some of the air box system was loose. I tried a few things and the only thing that worked was sponge to keep compression on the air system and It moved with the vehicle. The warning went.

Then it came back and so I went back to garage and they said they could not fix it better, it went off.

Now its back again and it wont go. Ive tried cleaning all the electrical contacts but it still here and in limp mode. I need a fix because ive got to travel 300 miles to morpeth on the 27th off December.

I know its Christmas but does anyone have a fix????

Many thanks for reading

Vic
 

·
Registered
Joined
·
14,253 Posts
The fault could be caused by lots of things the first thing you would need to do is read fault codes using a code reader that reads faults on Peugeots PROPERLY.

reading faults is a guide to what is wrong but do not go down the route of replacing anything that has a fault logged as this rarely cures issues most problems on these are caused by wiring issues causing faults rather than the parts being faulty.
 

·
Registered
Joined
·
42 Posts
Discussion Starter #4
Ive tried contacting a member in my area on holiday but nothing back as yet. Im not sure if its related but I now have a sort of metal sound in the car like a sort of lathe sound. When i disengage the engine its still there but again It doesnt happen all the time. This car is made worse im sure by being a van first and car second lol.
 

·
Registered
Joined
·
2 Posts
Fixes for that

Get mechanic to check fuel filter. Or do yourself..
Sounds exactly like what my van did, random limp mode..
New filter in and as good as new! :)
 
1 - 5 of 5 Posts
Top