Peugeot Forums banner

1 - 20 of 20 Posts

·
Registered
Joined
·
65 Posts
Discussion Starter #1
got a 59 hdi van, and am starting to hate it,

the problem this week is the anti pollution keeps coming on and van limps home or cuts out completely, get to a garage its fine, lights are out and drives fine, then next day does it again, cuts out why I am driving, so struggle to stop, it seems to cut out completely and battery light comes on, then wont start and gets towed home, put in garage and they cant find prob, as not showing any codes

the problem seems to happen when the roads are wet, as for 2 years I had no probs with anti pollution, but if I drive when roads are wet, it will cut out, only been happening over the last month

been told, replace ECU, replace full exhaust, give it a other service

all guess work, as no one can find a code for it


any ideas?
 

·
Registered
Joined
·
65 Posts
Discussion Starter #4
just been out to move van, and its gone off again, every thing is back to normal, have checked for water getting in air in take, as was told this was a poss as well, bone dry

only seems to play up in the wet weather
 

·
Registered
Joined
·
14,298 Posts
If it only plays up in wet weather it has to be electrical

Anti pollution fault is a generic fault it means nothing on its own lots of faults will make it come on

Sounds a silly question but is your underbonnet fusebox cover complete and properly closed
 

·
Registered
Joined
·
65 Posts
Discussion Starter #6
yea, cant find a reason for it, when it comes on, I cant get it in the garage, when it gets looked at, it gone and no code,

going to change the air filter tomorrow, see if that helps and
 

·
Registered
Joined
·
14,298 Posts
It should be storing something as any fault that puts engine light or antipolution fault on should log a code

Saying that live data is usually more usefull in diagnostics
 

·
Registered
Joined
·
65 Posts
Discussion Starter #10
how I am only telling you half the story, my anti pollution comes on when its wet only, take garage they say there no faults,

it was only when the bloke said electicaly, that I thought the battery might have some thing to do with it, as I didn't think a dead battery would cause the anti pollution to come on

all I can go off is what the garages are telling me after I get van back

I had a prob like this the other month, with the air bag ecu, put in a garage, they said, cant find fault code, but light wont go out, put in other garage and they found faults, but they where all unknown, in end replaced ecu was fine, then the hand brake light came on, that turned out to be a switch had come out, seems to go from one prob to a other with this van
 

·
Registered
Joined
·
65 Posts
Discussion Starter #12
found this on a wire that runs from battery pos to the back of the van, will this be causing me all the probs

 

·
Registered
Joined
·
65 Posts
Discussion Starter #14
lol, I know

it runs off the battery pos and runs a pump,

if that was touching metal on van will it drain the battery
 

·
Registered
Joined
·
65 Posts
Discussion Starter #16
The wire didnt sort the problem. Had it in peugeot all they said was cpmputer says charge battery. Replaced battery anti poll came on again. Managed to get codes they where

p0087
P0093 both read fuel delivery control less than minimum

error sporadic

Any idea. As the local peugot garage aint got a clue and am sick of paying them money just to go back day after with same problem
 

·
Registered
Joined
·
65 Posts
Discussion Starter #17
Also when it is driving normally and it comes on the van runs crap. But if I stop and turnn engine off and back on it runs normally for a bit

it is like the fuel filter or injectors are blocked. But none of the garages will give me a straight answer. Just might be this might be that

sometimes I rev and it wont go over 3k other times it is normal
 
1 - 20 of 20 Posts
Top