Peugeot Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Iv had my 307 for almost a year and since the first day iv had it iv intermittently had the anti pollution fault it sometime will come on as soon as the car moves or it can be after a few miles but most of the time it won't come on at all. I accidentally broke my maf sensor while cleaning it :( but the car runs a lot better and faster now it's unplugged (new one is on it's way) could the maf have been the problem? Occasionally still get the fault while it's still unplugged though. Also if the fault has been fixed would it still have to be cleared before I stop getting the fault?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #2
forgot To say it's a 2002 90bhp hdi. When I get the fault it looses power but if I turn the engine off leave it a min or two it goes back to normal again
 

·
Moderator
Joined
·
11,766 Posts
I've not come across any warning message when the MAF is disconnected on a 90bhp 307. I had a 51 plate and had my MAF off for a while.

The fault warning is pretty generic, you'll need to get a Planet diagnostic done. See the sticky for more details.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #4
I've not come across any warning message when the MAF is disconnected on a 90bhp 307. I had a 51 plate and had my MAF off for a while.

The fault warning is pretty generic, you'll need to get a Planet diagnostic done. See the sticky for more details.
I'm trying to find somewhere to get it done as I don't have a local Peugeot to do it. Could exhaust cause the fault as my back box droped off because of corrosion when I got a new one fit the said the rest wouldn't last long
 
1 - 5 of 5 Posts
Top