Peugeot Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi everyone,

Here is my issue with
Peugeot 207
Year 2010
Diesel, 1560 cc
66 000 miles

Problem:
Anti pollution warning lamp
For the last 6 months I have been frequently getting anti pollution warning on the dashboard.
It than does one of two things.
1. Cut the engine. I have to stop. Leave it for 30 seconds and I can start the engine again. It drives without any problems. I have done more than 5 000 miles like this without any issues.
2. Restricts the engine at 3000 rpm. I can continue driving without any issues just have to switch gears at 3000 rpm.
My observations:
I have not noticed any additional noise from the engine. Have not noticed any increased fan speed/work. At times I have noticed a bit more smoke coming out of exhaust for the first 10 seconds or so after it is started again.
I also noticed that the likelihood of this warning appearing increases if I drive in lower revs and higher gears. If I keep reving it up in lower gears it is less likely to appear.
Also of note is that the car has passed MOT and emission tests in the mean time without any issues.
In my layman opinion there is nothing major wrong with the engine. It seams to be working fine and it seams to be only restricted by electronics.

Any advice would be very much appreciated. In terms of what you think this might be or how to go about fixing it in London.
Thank you very much for your time and advice.
 

·
Registered
Joined
·
38 Posts
Hi mate my 58 reg 207 1.6 hdi is doing the same I've had it on diagnostic computer and it shows no fault. I've got my car booked in for remap dpf clean and egr delete I will let u know if this work stop anti polution stops coming on once work is completed
 
1 - 2 of 2 Posts
Top