Peugeot Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Peugeot 207S 2008 petrol, engine management stays on with above fault that comes on then goes off, with fault P0343.Had 2 sensors fitted but this not worked, had garage check sensors and they say there is nothing wrong with them, also had solenoid valve fitted. driving me mad any suggestions please?
 

·
Registered
Joined
·
15,377 Posts
Antipollution fault is NOT a fault its a message telling you something is wrong which will potentially cause excess pollution.

Whatever is putting the engine light on is the real fault ignore the message concentrate on the real fault
 

·
Registered
Joined
·
108 Posts
Thanks for your reply are you saying the fault I should be looking at is P0343?
you need to know what P0343 fault code means and then as 406 says you have to understand what is causing this fault to come up, i had anti pollution fault show on display in my car but again like 406 said its a general message meaning there is something amiss and your car is causing pollution over and above the stats your car should make. In the end mine was the PCV valve not working and using too much oil and causing smoke to come out from exhaust, fixing this cleared the fault.
 

·
Registered
Joined
·
15 Posts
Been plugged into diagbox tonight fault reads as p0343 inlet cylinder reference sensor signal fault.

1 sensor was replaced and light went off for around 3 month theb 2nd sensor was replaced which lasted less than a day

I erased the codes but came back after a short drive.

Could this be that timing is slightly out?

Car is 08 with only 25000 miles !
 

·
Registered
Joined
·
877 Posts
check for a slight misfire, clean or replace inlet solenoid valve.

when we had this code earlier this year along with a camshaft code we swapped cam sensor first then changed solenoid, but camshaft code came back after a few weeks, then went for a drive and noticed a slight stutter every so often, so swapped out the coilpacks and lubed them up so they sat nice on the plugs, then all codes went.

If you think you can feel a slight misfire, could just buy 1 coil for diagnostic as the ecu wont report a fault until its misfired alot.
 

·
Registered
Joined
·
15 Posts
Inlet solenoid valve has also been replaced. Couldnt report on feel of enginer as the car beling to chris who had posted further up, didnt sound like it was misfiring though
 

·
Registered
Joined
·
6 Posts
Discussion Starter #9
Fixed

Special thanks to Jason for putting my car on his diagnostic computer. He was right took it back to the garage today and they had put a cheap faulty sensor in, and told me it was a Bosch, just liked he said. Sorted once agian thanks.
 
1 - 9 of 9 Posts
Top