Peugeot Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
Hi guys,

I drive a 307 2.0 litre petrol xsi.

Today while sat at some traffic lights, the engine management light came on along with 'anti pollution fault'

Every time I start up the anti pollution fault appears and then goes and doesn't re appear. The engine management light on the dash stays on though.

The car drives perfect still and has full power.

About 800 miles ago (3 weeks) I had a new cat fitted, oil changed, timing belt changed and a new second hand engine fitted with new spark plugs and ignition coil.

So I imagine it should be any of this causing the problem.

I see this appears quite common with the 307 - I just wondered if there was anything I can do? I want to avoid going back to the garage as I have spent a small fortune recently.

Or will it be a case of getting the fault codes read to see what is causing the warning? - if it is, I may by a reader myself, what should I go for?

Am I ok to drive this around until I get it looked at?

any help is very much appreciated;

Andy
 

·
Registered
Joined
·
15 Posts
Discussion Starter #3
Thanks for the reply. The fault disappeared on Saturday and hasn't returned. Iv done another 200 miles and it still hasn't come back so I guess I'll just wait and see if it comes back. If not then happy days, if it does I'll be getting in contact with someone with one of these dianostic scanners :) I hope you haven't jinxed me lol - touchwood
 
1 - 4 of 4 Posts
Top