Peugeot Forums banner

1 - 20 of 21 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Right where do i start i am now the owner of a 2002 pug 307 2.0 rapier petrol.right when i got the car there was an eml on and told it was the 02 sensor rear left bank so i took my own diagnostic machine plugged it in and voila code p0141.
so upon driving home i noticed the exhaust has a blow and the speedo doesnt work nor the trip but the rev counter does upon checking the mots online the speedo hasnt worked for a while as the mileage hasnt moved.
The car had a single din stereo fitted so the multi function display didnt work i was given the original stereo system so today i put it in and it never worked so i checked the mfd and it was unplugged so in it goes and yay the stereo works yay or maybe yay not as i have now found 3 faults showing abs fault/brake fault and filter fault however theres no fault coming up on the diagnostic machine nor is there any other warning lamps lit.
Next thing ive noticed is the lack of warning lamps when ignition is turned on i think ive got 3 light up thats it not right at all
so do you think theres a link to all the faults or are they just been hid can the speedo be linked to the lights not showing and why doesnt the machine find any faults other than the 1 listed.
Oh incidently the car runs mint ticks over fine and drives without fault
private sale well swapped my corsa c and no answer from them as yet.
Any help would be kinda helpful thanks in advance.
 

·
Registered
Joined
·
171 Posts
Sounds to me like the MFD was unplugged to hide the faults, I had the same thing done to me.

Regarding the lack of lights on the dash when the ignition is switched on I also had the same thing, and this is what I found...

Before:



The bar-steward had covered up the back of the engine and ESP lights with black insulation tape so they didn't show on the dash!

After:



Maybe they did the same to yours?
 

Attachments

·
Registered
Joined
·
171 Posts
It's possible the car's software has been modified to not show the faults but I think the most likely reason is that your code reader is simply not capable of reading all of the faults on this particular car.

I would suggest finding someone with Peugeot Planet and getting a diagnostic done (many forum members do it much cheaper than main dealers).
 

·
Registered
Joined
·
10 Posts
Discussion Starter #5
is that possible not to pick up simple codes like brake and abs warnings ive used it lots of times on lots of cars and found all faults and cleared them yet this one only shows 1
 

·
Registered
Joined
·
171 Posts
is that possible not to pick up simple codes like brake and abs warnings ive used it lots of times on lots of cars and found all faults and cleared them yet this one only shows 1
Honestly I don't know. If you post the type of reader you're using then someone else with more experience may know but in all honesty they'll probably just suggest getting a Peugeot Planet scan done as I think that's the only way to be sure.
 

·
Registered
Joined
·
437 Posts
I've read that some scanners cant read P codes above P1000. Not sure if there's any truth in that but it might be worth finding out what a P code would be for the faults you have and if above P1000 might explain it???
 

·
Registered
Joined
·
10 Posts
Discussion Starter #12
it was a woman whod had it for 2 yrs she said so i swapped her my corsa now im left with a prob expensive fault
 
C

·
Guest
Joined
·
0 Posts
it was a woman whod had it for 2 yrs she said so i swapped her my corsa now im left with a prob expensive fault
Ok Serious Advice time.

Search on here for the Planet Map have a look which member on here is nearest to you with the Planet Diagnostics kit contact them and get them to do a full diagnostics on your car for a few beer tokens then post the results on here. Someone like DavidIreland or GIbbo will help with interpreting the results and hopefully we can get your car fixed cheaply and quickly then hopefully you can put all this down to experience and enjoy your new purchase :thumb:

Sandman1976 - Halifax
Stetodd - Leeds
Daz walsh - Leeds
DALE2321 - Wakefield
 
P

·
Guest
Joined
·
0 Posts
As has been mentioned already, a full diagnostic using the usual tools with give you a better view of what is going on.

The abs fault are not end of world, they're bloody annoying, but easily sorted. Could be the usual rust that needs cleaning off, could be like I had, a stupid broken wire.

Disgusting they covered the lights over, bad form, very bad form.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #17
ive spoken to the last owner a young lass with a young kid and shes horrified stating she knew nothing anyway what are the sensors are they on all 4 wheels or just rear and would that bring abs and stop and brake lights on.whats the filter error
 

·
Registered
Joined
·
171 Posts
ive spoken to the last owner a young lass with a young kid and shes horrified stating she knew nothing anyway what are the sensors are they on all 4 wheels or just rear and would that bring abs and stop and brake lights on.whats the filter error
Sensors on all 4 wheels and yes, if they're not producing a coherent signal for the ECU, they could light up the brake, ESP/ABS and STOP lights.

Filter error could be a whole host of things, diag needed.
 
1 - 20 of 21 Posts
Top