Peugeot Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1 (Edited)
ok so the other day(a cold one) it took a couple of goes to start the car, started got the usual antipollution fault, nothing unusual there, until i start driving :D . iv never experienced my car being as fast since i got it, i was amazed at the power it had, and it had it in every gear.i think i could even hear the turbo winding up. i really enjoyed having this power but it only lasted for a while, started it up later that night, got the antipollution fault again but with no extra power :nono:

Can anyone explain why this happened or how i can get it to happen again? or is this the kind of power im suppose to have all the time? normally my caar doesnt really have much after 3000 revs but on this day it kept going?

one extra detail, i had this car for a 100 mile long motorway drive the day before this happend
 
D

·
Guest
Joined
·
0 Posts
If its a 307 1.4hdi they usually have problems with the catalytic converter breaking up and blocking the exhaust. The broken piece may have moved around and unblocked the exhaust.
This is a common issue on 1.4hdi.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #3
If its a 307 1.4hdi they usually have problems with the catalytic converter breaking up and blocking the exhaust. The broken piece may have moved around and unblocked the exhaust.
This is a common issue on 1.4hdi.
so would this mean just taking off the cat and breaking out the inside, then replacing? thanks
 
D

·
Guest
Joined
·
0 Posts
Break out the inside and fit it back on. They usually pass the NCT without it.
 
1 - 6 of 6 Posts
Top