Peugeot Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
31 Posts
Discussion Starter · #1 ·
Hi All,

It's been a LONG time since I have posted on this forum, but I have an issue and wondered if anyone can help me out with it.

My wife's drives a Peugeot 206 1.1 LX 2002 Registered on an 02 plate. It's now done 53,000 miles. About 2 years ago she had a problem where the airbag light would come on and then off again, when we asked Peugeot about this they advised to replace the ECU, which we did, to the tune of £220! :(

However, the same problem is happening again, and has been, intermittently, for the last 18 months or so.

Surely, the ECU unit doesn't have top be replace again. Is there anything that I can try to remedy this problem or does anyone have any advice?

Cheers,
Picco
 

·
Registered
Joined
·
77 Posts
You will most likely find that as with all the peugeot and citroens it will be the pretensioner connections under the seat not making very good contact causing the light to come on intermittently.. You can disconnect and clean them. but i would advise disconnecting the battery first... If you have a bsi module on the vehicle then there is a specific way to reconnect the battery.. Don't have the details to hand...
 

·
Registered
Joined
·
857 Posts
crmpicco said:
Hi Chrissy,

Thanks for the reply. Where abouts under the seat am I likely to find the pretensioner connections? Not sure about a BSI module, it's just a LX, not the GLX.

Have you heard of this sort of problem before?

Cheers.
hi, if you look under the front seats, you will see wires with plugs, disconnect the plugs, wait a few seconds and reconnect again, but before you do that, disconnect the battery first, then check the connections under the seat...
ps: your ECU may not need replacing but it may need an update..
regards
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top