Peugeot Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
195 Posts
Discussion Starter #1
Hey guys!
so today's problem is this ('04 307 hdi xsi 2.0L 136bhp), i changed the steering wheel on my car about a month ago for one looking less ratty.
The airbag light on the dash and the central display has been quite good in keeping me informed there is a fault with drivers airbag, PP2K says its both level 1 and level 2 Fault on the drivers module.

I'm telling this for clarity as today the car has decided to constantly, ceaselessly and maddeningly keep cycling a three tone beep for want of a better description. Now i've ordered another comms2000 unit in the hope it may be a damaged cable as the airbag was transferred over from the old wheel to the new one, so the airbag itself is fine, though the three ribbon cables (blue/yellow,green/yellow and grey) all appear to be ok, they must have been damaged.

Is there a short term fix i can do to shut the system up or fool the airbag ecu until the replacement comms 200 turns up? it's my daily driver and i fear i may fall even further off my rocker if this isn't tended to, and soon.
 

·
Registered
Joined
·
195 Posts
Discussion Starter #3 (Edited)
Thank you

I tried a 2.2ohm resistor in each of the pin slots and a 3.3ohm in each and neither worked.
I'll turn up the stereo while driving and pray the comms 200 turns up sharpish!
God knows whats wrong but thank you for the guidance.

So the comms 2000 turned up and i got it installed but its still showing airbag fault, and has rather an odd noise if the drivers door is open, do these things need setting up in planet?
 
1 - 3 of 3 Posts
Top