Peugeot Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi everyone, newbie here.

Had my van for about a year, after a month of having it the airbag light always remained on, I ignored it up until now as my mot is next month, I've managed to fix the issue, all I did was remove airbag and clock spring and refitted now the light goes out after the engine is turned on....but
When I turn the key to ignition all the dash lights illuminate (as normal) but the STOP light also illuminates (dont remember that normally happening) and then air bag light goes out (before engine started). The when Ido start the engine all lights go out and everything is fine.

If I remember rightly the airbag light is meant to go out after a few seconds of engine running, and I've never seen the stop light on before, am I missing something?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Ok so turns out that the problem was fixed only for a week or do, I've discovered that the ribbon cable on the clock spring is damaged.

After searching endlessly for a spare comms unit I've been unsuccessful in finding the one I need, can't find one that matches the part number for the one I have, as I was told it HAS to be matching part number. Is this true?
I also couldn't find a spare clock spring, so I'm thinking, does anyone know if it's possible to get a comms unit (as similar as possible) and use the clock spring from that, as most if them appear the same. Am
I right on thinking the clock spring only provides a circuit to the airbag and horn, I've tested to see if the spring comes apart from the comms and it does. Would this work?
 
1 - 3 of 3 Posts
Top