Peugeot Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi everyone, excellent site & have picked up some useful tips thanks. I have a 307 sw 02 plate HDi 90 (I think!) it's not the 110 anyway. The car has been vibrating and has a very loud idling noise which isn't so apparent when you are driving it, took it to peugeot dealer twice & they replaced the pre tensioners, wasn't that. Then they wanted to order some huge part - I can't remember what it was but cost about £400. Not overly impressed, we took it to an independant who said he thought it was the air compressor unit. Could this cause the noise I've mentioned? I'm new at this and am no mechanic but am getting tired of being given conflicting opinions, just want to get the damn car sorted!! Any help muchly appreciated, thanks. :confused:
 

·
Registered
Joined
·
862 Posts
i like the glass roof said:
Hi everyone, excellent site & have picked up some useful tips thanks. I have a 307 sw 02 plate HDi 90 (I think!) it's not the 110 anyway. The car has been vibrating and has a very loud idling noise which isn't so apparent when you are driving it, took it to peugeot dealer twice & they replaced the pre tensioners, wasn't that. Then they wanted to order some huge part - I can't remember what it was but cost about £400. Not overly impressed, we took it to an independant who said he thought it was the air compressor unit. Could this cause the noise I've mentioned? I'm new at this and am no mechanic but am getting tired of being given conflicting opinions, just want to get the damn car sorted!! Any help muchly appreciated, thanks. :confused:

Is the idle erratic at all?
 

·
Registered
Joined
·
66 Posts
I had a similar problem as a droning noise came on when the A/C was on. After parking in my driveway I noticed a cylindrical object that seems to have came off the bottom pulley and the noise is no longer there?

Anyone have any ideas if tis is the Aircon Clutch?

My mate says it needs a split pin to fit it back on as the bolt is still on the end of the pulley. Is this correct?

Thanks
Alan
 

·
Registered
Joined
·
15 Posts
I think it is either compressor or Aircon Clutch problem. this is the case when the noise comes when switching the AC on BUT if the noise is always eventhough the AC is off it is probably from one or both of the pullies above thye Aircon Clutch. they need changed. Actually I had same problem and I changed both of them so the noise gone.

hope is it helpfull
 

·
Registered
Joined
·
66 Posts
m_khamis2002 said:
I think it is either compressor or Aircon Clutch problem. this is the case when the noise comes when switching the AC on BUT if the noise is always eventhough the AC is off it is probably from one or both of the pullies above thye Aircon Clutch. they need changed. Actually I had same problem and I changed both of them so the noise gone.

hope is it helpfull
Thanks. It must be the aircon clutch as it fits on the bottom pulley but the circlip has gone so it worked it's way off.
 
1 - 5 of 5 Posts
Top