Peugeot Forums banner

1 - 20 of 41 Posts

·
Registered
Joined
·
43 Posts
Discussion Starter #1
My 2002 307 2.0HDI 110 failed it's MOT yesterday due to the Air Bag Light staying on. When you start the car it beeps twice, tells you there are 2 Air Bag Faults and the light stays on the instrument/speedo cluster.

It's been on for a while now and passed the MOT last year but apparently as of the 1st April 2013 this is now a failure.

I'm assuming the lights are LED's so can't be removed and also that by looking at removing a fuse I would possibly cause more trouble or stop other things working.

Strange thing is-is that the light and errors will go once the weather warms up. When the temp is 12-15deg the Air Bag's function normally. Sods law my MOT is due in April.

Any ideas? I've got 10 days for the free test but can't drive my car in the meantime due to the failure.

Thanks

Joe
 

·
Registered
Joined
·
464 Posts
Removing the light, LED Or Bulb won't help - the new test demands that the airbag light comes on initially (system test) and then goes out. Only real solution is to find out exactly what the problem is, and get it fixed :(
 
D

·
Guest
Joined
·
0 Posts
Get a diagnostic check done. Post the faults up here and we can help you.
 
P

·
Guest
Joined
·
0 Posts
My 2002 307 2.0HDI 110 failed it's MOT yesterday due to the Air Bag Light staying on. When you start the car it beeps twice, tells you there are 2 Air Bag Faults and the light stays on the instrument/speedo cluster.

It's been on for a while now and passed the MOT last year but apparently as of the 1st April 2013 this is now a failure.

I'm assuming the lights are LED's so can't be removed and also that by looking at removing a fuse I would possibly cause more trouble or stop other things working.

Strange thing is-is that the light and errors will go once the weather warms up. When the temp is 12-15deg the Air Bag's function normally. Sods law my MOT is due in April.

Any ideas? I've got 10 days for the free test but can't drive my car in the meantime due to the failure.

Thanks

Joe
Is it not a case of checking the connections under the seats like you had to do in 306's? Usually turns out to be a bad connection?
 

·
Registered
Joined
·
43 Posts
Discussion Starter #5
I've disconnected and reconnected the cables under the front seats but the light is still on with 2 beeps and 2 airbag fault messages. Only happens when it's below 10deg :confused:
 

·
Registered
Joined
·
43 Posts
Discussion Starter #6
Had the car on Planet this evening and the fault came back as -

'Airbag - Permanent Fault - Satellite Right'

Reset the error codes but the fault returned straight away.

What is the Satellite Right? Is it the Seatbelt airbag connection as I had this replaced about a year ago when the Seatbelt locked but I can't remember if the error happened before or after.

Any help would be greatly appreciated as I can't drive the car at the moment.

Thanks
 

·
Registered
Joined
·
43 Posts
Discussion Starter #10
Can't find one on Ebay. Am I searching for the wrong thing or do I need to request one from a breaking car?

Do I need to disconnect the battery before replacing the satellite?
 

·
Registered
Joined
·
43 Posts
Discussion Starter #12
Going to try and locate it now to see if it's yellow or black. Can I disconnect and reconnect? If so do I have to disconnect the battery? last thing I want at the moment is a deployed Airbag!

Thanks for your help.
 

·
Registered
Joined
·
43 Posts
Discussion Starter #13
Removed the trim and carpet, can see the yellow sensor with the black connector. Just need to know if I can disconnect/reconnect or replace safely without having to disconnect the battery.
 

·
Moderator
Joined
·
5,812 Posts
For safety i would disconnect battery wait 15 mins then disconnect sensor. If your car is pre facelift then should be yellow sensor.

When disconnecting/connecting battery follow BSI reset procedure to be safe
 

·
Registered
Joined
·
43 Posts
Discussion Starter #15
Disconnected and reconnected the Satellite sensor but the airbag fault still remains. Next step is to replace the sensor, any ideas how much from a Dealer?

Thanks
 
D

·
Guest
Joined
·
0 Posts
The satellites give trouble. You have to replace two of them. There is an info flash on it. So the dealer will know. a certain batch of them from factory are dodge.
Replace both and clear the faults. Baring in mind make sure all the wiring is ok first theough. From each satellite to the ecu.
 

·
Moderator
Joined
·
5,812 Posts
Sensors for early model sold in pairs by dealer PN 8216.AL £75.41 inc vat is price listed in Servicebox
 
1 - 20 of 41 Posts
Top