Peugeot Forums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Hi there my diesel 2.0 occasionally wont accelerate even though I have the pedal to the ground, it tries to accelerate but hesitates. Any ideas its a 2002 model. it seems to be when cold and gear changes in low revs. accelerator pedal okay.

Best Wishes


Howard
 

·
Registered
Joined
·
196 Posts
pendleh said:
Hi there my diesel 2.0 occasionally wont accelerate even though I have the pedal to the ground, it tries to accelerate but hesitates. Any ideas its a 2002 model. it seems to be when cold and gear changes in low revs. accelerator pedal okay.

Best Wishes


Howard
you might wanna get the codes read as it could be a number of things
 

·
Super Moderator
Joined
·
1,807 Posts
does it just not go or is it accelerating in bursts?
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #6 ·
stevoxsi said:
does it just not go or is it accelerating in bursts?
Hi stevo

Its hard to describe but I will try. Think its a mechanical fault as no lights on dashboard. The acceleration sticks, car judders even though I have foot on the gas for more power have to change down a gear and then its okay. Happens intermittently. Almost as if the fuel pump has a funny one? What can I try to diagnose the problem? What areas should I look at? Thanks for your input!!!!

Best Wishes

Howard
 

·
Registered
Joined
·
534 Posts
pendleh said:
Can any garage with diagnostic equipment do this or is it peugeot dealer?
If the garage has previously seen the problem and tackled is successfully, they might be able to but usually they won't have. However, the dealer has a all the software to plug into your car and get a pretty good idea where the trouble lies. The software checks everything and then reports back with troublesome parts. If done by a good operator, who can link the results to known probable causes, it's far better than guessing.
 

·
Super Moderator
Joined
·
1,807 Posts
In mine the power came 'lumpy' mainly caused by the turbo repeat sensor. The other thing that comes to my mind would be the airflow meter is faulty.
 
1 - 8 of 8 Posts
Top