Peugeot Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi guys,

I am looking for some advice on where to get a wheel speed sensor/ ABS sensor for the rear left hand side of my MK3 308. I have tried euro etc and they dont have it. On looking at the sensor already in place, it looks like it is connected straight into the loom? I'm getting the usual ABS/ESP/SERVICE/Tire inflation warning lights on the dash. Cruise and speed limiter also do not work when this is on.

Cheers!
 

·
Registered
Joined
·
1 Posts
hi stuart ive had a similar issue with my 308 had it at local garage who had it on diagnostics which showed up rear passenger wheel sensor so gave ahead to replace it and he cleared codes only for it to come up again stumping us both as to problem,thinking im needing to put it into dealers i tried these forums but to no avail.Anyway i looked online and found a local peugeot expert and put car in and long story short turned out a wire running to rear sensor had frayed rubbing against wishbone he replaced wiring and reset codes and presto all working again including stop start that had stopped working about six months after getting car so simple fix not to say i wasnt worried as thinking was gona be expensive repair i do hope this helps
 

·
Registered
Joined
·
15,377 Posts
A fault with a speed sensor does NOT mean you need a new sensor it depends on the EXACT wording of the fault not just the code the words give you a clue to the actual reason
Open circuit could be a sensor but could also be a broken wire/bad connection on the main loom
implausible/range performance or other similar wording can be the ring on the actual hub causing faulty signals replacing sensor wont fix this.

A poor battery can also cause ABS issues !

We need all the info
 
1 - 7 of 7 Posts
Top