Peugeot Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter #1
After blue-tacking over the abs light for the last MOT, unfortunately this year the tester noticed the fact the light didn't illuminate as it should at start-up. Therefore I now need to fix the bloody thing.
Iv scanned it with Peugeot Planet, and it tells me something along the lines of an 'open circuit to rear right wheel sensor'.
After changing the sensor, it still throws up the fault, so would i be right in guessing it is either a broken wire between the sensor and the module, oR the module playing up?

I will test the wiring at the weekend by switching the two sensors around at the module to see if the fault changes sides.

My question is whether its possible just to switch the module, so I don't have to bleed the whole system? And if so will the replacement need re-coding to my car?

Many Thanks, Graham.

52 307sw 2l HDI

:confused:
 

·
Registered
Joined
·
343 Posts
Hi

Firstly is this the warning light for ABS and the multi function display message that appears "ABS/ASR Faulty"?

If so it is probably the sensor air gap issue on the rear wheels. This would be my first port of call as your model is prone to this issue.

I had the same issue but luckily Peugeot passed the MOT for me despite the light on the instrument panel.

There is a good tutorial on the site here but it is literally cleaning the rust from the sensor mounting plates and then refitting so the gap is no more than 2mm.

Take it down the road and all errors are fixed.

Good Luck

Matt
 

·
Registered
Joined
·
23 Posts
Discussion Starter #3
ABS & ESP warning lights on the instrument cluster, and the messages on the display.

I've already tried cleaning the rust off and have replaced the sensor, which is why i'm confused as to what it could be.
 

·
Registered
Joined
·
343 Posts
With your questions,

a) The system has to be bled in order to replace the ECU. The ECU is integral with the regulator assembly so the lot has to be replaced.

b) I am not sure about coding but I would have thought Peugeot Planet is enough for this job if you state you have it?
 

·
Registered
Joined
·
343 Posts
ABS & ESP warning lights on the instrument cluster, and the messages on the display.

I've already tried cleaning the rust off and have replaced the sensor, which is why i'm confused as to what it could be.
I had to revisit the sensors 3 times before I had cracked it. The rust literally has to be scraped off till you see bare metal. The sensor is not fixed unless the air gap is about 2mm and the sensor is completely level on the flat surface.

It was tricky until it finally worked so maybe worth revisiting to just check before you splash out on a new ECU.

Personally I recon 80% of the ABS/ASR/ESP issues are solved by the rear wheel sensor clean.

EDIT: Also when you say you replaced your sensors, if they were not genuine Peugeot this could be your issue. I have read that the cheap ones off Ebay can be a problem with the vehicle recognising them.
 

·
Registered
Joined
·
23 Posts
Discussion Starter #6
Sounds like I've got a busy weekend then :shrug2:

No harm in giving cleaning it another go, its just after clearing the codes the fault comes back as soon as the engine is started..
 

·
Registered
Joined
·
343 Posts
I would also say tutorials state the fault should go once restarting the engine. Total rubbish. I had to take my car down the road for it to clear the errors and never return. If you are clearing the fault via PP2000 then if it comes back the issue is obviously not solved.

It could well be your ECU but what I am saying is be sure it is before you spend money and time replacing it to find it was never the issue in the first place. Exhaust your options first and the rear wheel sensor trick is one easily overlooked in these circumstances.

Good luck!
 
1 - 7 of 7 Posts
Top