Peugeot Forums banner
1 - 12 of 12 Posts

·
Registered
Joined
·
48 Posts
Discussion Starter · #1 · (Edited)
My wifes 307 90 hdi, ABS light has recently started coming on intermittently.

Someone mentioned it could be the air gap that is incorrect between disc and sensor. What should the air gap be.???

thanks
 

·
Registered
Joined
·
48 Posts
Discussion Starter · #2 ·
Does anyone know what the air gap should be with the ABS sensors on the hubs????

thanks
 

·
Registered
Joined
·
48 Posts
Discussion Starter · #4 ·
Thanks,

I've just been out to the car and can't find where my wife has put the Handbook.

Just to be sure the light that comes on intermittently shows a car with skid marks, is that the ABS or ASR.

thanks again :thumb:
 

·
Registered
Joined
·
48 Posts
Discussion Starter · #6 ·
thanks,

I'll check the sensors and any rust etc tomorrow.

The brakes are fine at present without any judder etc, just that the warning light comes on intermittently.

A couple of years ago it was recalled for a check on the ABS (water ingress etc). ??

Any ideas where they would have checked or resealed, and where to find whatever they checked, to check for any corrosion in the connections etc.
 

·
Registered
Joined
·
9,731 Posts
If you open fuse box in the engine bay you will see what they done, probably looks like a load of melted plastic, is your abs kicking in yet feels like a thumping when braking.
 

·
Registered
Joined
·
48 Posts
Discussion Starter · #8 · (Edited)
Thanks


No, the ABS don't kick in. Just after travelling approx. 5 miles the warning light will come on and stay on till switching off ignition for approx. 15mins or more at where ever I park for a time shopping/fuel etc.

The Fuse box under the bonnet N/Side looks normal, with number of fuses and plug-in's, with the ECU to the front.

Having come back from road test, still same with W/L and dash display coming on warning of ABS fault.

But no ABS shudder or thumping when brakes applied. ?????

Thanks
 

·
Registered
Joined
·
48 Posts
Discussion Starter · #10 ·
thanks :thumb:

I'll check that connection tomorrow.

reading various topics about the failures on ABS of the 307, some mention the ABS ECU getting ingress of water, didn't know that there was a separate ECU for ABS. ??

If so where ??
 

·
Registered
Joined
·
48 Posts
Discussion Starter · #11 ·
All done and dusted.

Fault is now cured, fingers crossed.;)

When cleaning the sensors, noted the back plate part was rusted with flaky rust. Removed this and I noted one sensor was greater than 2mm from the toothed spider on the rear side of the rear hub. Normal flat washer was too thick, so made my own and now sensor is within 2mm.

So all is cured.

Thanks for your help. :thumb:
 
1 - 12 of 12 Posts
Top