Peugeot Forums banner

1 - 20 of 34 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter #1
SEARCH IN THE CURRENT
AND SHOW ME
[email protected]
Junior Member
Join: 1 day ago
Posts: 1

1 day ago · #1
Abs control module issue
Hi all, had my pug a whole now it's a 2015 pure tech allure. I blew a tyre and the abs, esp, under Inflation lights came on and the cruise control stopped working. With the tyee replaced I could see a severed cable on the front left wheel. I purchased a new cable and sensor and replaced, took maybe 5 mins as was straight forward. Now my car has all the same faults still but also the speedo has stopped working, the power steering is off and the eml is on. The rear parking sensor is off as well. I scanned it with my reader and get these faults:u0422 invalid data received from body control module and also u0121 data bus anti lock brake system Abs control module no communication. I cleared the dtc's on the scanner but it hasn't helped.
Any ideas please?
 

·
Registered
Joined
·
14,253 Posts
All your issues are to do with the ABS you need to check for any other damaged wiring and check the fuses under the bonnet.

PROPER diagnostics is needed reading data as well as codes if you cant find anything obvious
 

·
Registered
Joined
·
21 Posts
Discussion Starter #3
All your issues are to do with the ABS you need to check for any other damaged wiring and check the fuses under the bonnet.

PROPER diagnostics is needed reading data as well as codes if you cant find anything obvious
I have read codes and have u0422 and u0121 one is abs control module and one is body control module. The only issue was an abs light and esp etc which was clearly down to the cable as wasn't there before. Immediately after changing the cable the other issues kicked up. I'm hoping it's just that the ecu doesn't like the aftermarket cable and maybe it needs reprogramming or clearing as my odb reader is very cheap and basic. I've checked all fuses in engine bay and all are fine.
 

·
Registered
Joined
·
14,253 Posts
Those are codes you need DIAGNOSTICS both those codes start with U this is basically telling you things are not communicating thats what U codes mean IE the 2 modules they relate to this is only PART of the diagnostics you need more info to find out WHY they are not communicating and even if they are working the steering also has an ecu and needs signals from the ABS unit to work.
 

·
Registered
Joined
·
21 Posts
Discussion Starter #6
So, car went in today and they could not read diagnostics as the abs module has no power going in to or out of it. It's either dead or the cables are both split or fused together, which is unlikely. Issue I have now is noone seems to have a wiring diagram for this car. 😞
 

·
Registered
Joined
·
14,253 Posts
Thats EXACTLY what i expected your 2 codes relate to communication it wont communicate if no power OR EARTH dont assume it has no power no earth can do exactly the same as i said already you need to check fuses and wiring properly
 

·
Registered
Joined
·
21 Posts
Discussion Starter #8
Any ideas where the abs wiring is on a 2008?im guessing passenger footwell but after looking everywhere there is no mention of anything to do with abs in any of the three fuse box's.
 

·
Registered
Joined
·
21 Posts
Discussion Starter #13
OK so removed fuse box and under it are no fuses, tested all fuses and relays in the under bonnet box and all are fine. Removed cables from ecu and no signs of corrosion or damage. Removed wheel arch liner and checked all cables for damage and there is none. Checked the ground points and all are secure. Used multi meter on pins attached to abs unit and it shows power. Running out of ideas
 

·
Registered
Joined
·
21 Posts
Discussion Starter #14
I'm guessing most pugs had the maxi fuses built into the bottom of the fuse box but not the case with my 2008.The only confusing thing after checking everything is that if my multi meter shows rating when placed on the socket to the abs control module wouldn't this indicate that the module is ok? As everything points to the module failing I'm really stumped.
 

·
Registered
Joined
·
21 Posts
Discussion Starter #17
It's strange that there is no fuse for the abs system in the car. Unless it's controlled by a relay in the fuse box in which case as they are all fine it has to be the abs module
 

·
Registered
Joined
·
14,253 Posts
I can see 1 solid state fuse in the fusebox pic did you check that one that fusebox is totally different to most peugeot fuseboxes latest cars must have changed again !!
 

·
Registered
Joined
·
21 Posts
Discussion Starter #19
The top of the fuse box 2 threads? Yep has current. I'm gonna have one last go tomorrow and then order a new module. It looks pretty straightforward to swap out so fingers crossed 👍
 
1 - 20 of 34 Posts
Top