Peugeot Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
Dear All,

Pug 307 1.6 GLX; 2002; Petrol.

My ABS light comes on as soon as I start the car (even before I drive off)

The local garage first said it was the front O/S sensor which needed replacing.
Then on closer inspection, said that the sensor was fine but a rubber ring in the bearing had perished.
They would need to replace the bearing and possible the hub as well.

My question is that is the rubber ring not available on its own?
Why does so much need replacing for such a small thing.

Any help appreciated

Asghar
 

·
Registered
Joined
·
1,912 Posts
Sounds like the magnetic sensor ring has failed. The ABS sensor reads the wheel speed from the sensor ring in the bearing which is not repairable. Prices range up to £100 for an active sensor bearing before labour is included. This is the best I can tell you other than I cant see why a new hub would be needed.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #3
Many thanks for the advice....
Much appreciated.

I think I may just get a second hand full hub inc bearing as a remedy.

Save the pennies.
 

·
Registered
Joined
·
9,733 Posts
The only inspection you need is a Diagnostics , it will tell you exactly whats wrong as long as its done with pp2000 Diagnostics.:nod:
 

·
Registered
Joined
·
11 Posts
I had the same problem with the rear drivers side and yes it was a full hub replacement on mine. cost about £58 for the part and a couple of hours working out how to dismantle the callipers, and get the old hub off, Very very tight even with a big pair of 3-legged pullers but once it was off the new went on in about five minutes.
 
1 - 5 of 5 Posts
Top