Peugeot Forums banner
1 - 1 of 1 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi

I’m new to the forum and hope that someone can help.:)

307 1.6S
My wife’s car started having intermittent problems about a month ago with the power steering not working when she first pulled away, but after about 100m it would start working. The fault only happened about 4 times and not every day etc.
In between this issue was an ABS fault the normal stop lights and the speedo and rev counter would return to zero, but after a restart all was well.
The other night she was driving the ABS fault came up at the next set of lights she restarted and the ABS fault went away and the power steering pump has not worked since.

I have check the 70A supply is at the pump and also check the I/O plug all seems fine, I have even checked the speed input from the ABS ECU with a DVM (no scope at hand) at rest 0V and when going about 6.75V and then when stopping up to about 13.5V, which kind of implies speed. Which I guess means I have a faulty pump.

My question is do you think the ABS ECU could damage the power steering ECU, I don’t want to change the Power steering pump if it’s going to get zapped again etc. Or could this just be that there are two faults at the same time.

Took the car to a local garage, he said no codes form the ABS ECU or anything else:confused: His diagnostic equipment looked very impressive but it wasn’t Peugeot.

Has anyone repaired the pump or the ABS ECU?

Any help anyone can give would be great, I plan to order a power steering pump from BBA Reman tomorrow.

Many thanks in advance for any help.

Cheers
Mark
 
1 - 1 of 1 Posts
Top