Peugeot Forums banner
1 - 1 of 1 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Hi all
So I've got a Peugeot 407 2.0 hdi 2005 136bhp

About a month ago the dreaded ABS/ESP FAULT appeared on my dash. I took it to the local garage who ran it on the diagonstic machine and it showed a abs fault on the front drivers wheel on the sensor. So the sensor was replaced and the area was cleaned etc.....fault remained??!!

What is does at the moment...
Start car...fault appears...
I start to drive...fault disappears and I can brake fine...
After 10secs or so brakes feel like juddering when I push brake pedal...
Fault re appears and I can brake fine... this happens everytime!!!
So took to another garage (supposedly French experts!!) who plugged it into their diagonstic machine which still showed a fault with the sensor and some other random faults around the front drivers wheel area.

At this point I will mention I had issues in the past with light faults appearing etc which disappeared once i gave the rear light cluster connectors a clean.

Also at the moment I'm getting occasionally a fault for handbrake and electronic anti theft faulty- but keys work fine and so does the handbrake

So the garage believe it's an issue with the reluctor ring in the wheel bearing on front drivers side, with the magnet causing sensor issues. My first question is...is the reluctor ring in the wheel bearing? My old 307 has the ring on the driveshaft...
Second question...has anyone experienced this and have and suggestions?? The reason I meationed previously about light faults and rear light clusters is I've heard that the sensor could play up due to issues with earthing on rear light clusters. I've also read that the brake switch could be an issue??? But my brake lights work fine...
 
1 - 1 of 1 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top