Peugeot Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter #1
Right, probably this topic has been raised loads, as when I searched the net it seemed fairly common to have probs with 307 abs!

Anyway, i recently bought an 03 hdi rapier, abs light was not on at all in dash & multi function display was off too.

Firstly I fixed the loom to the multi function display & got it working, came up with abs fault.


I found pass fr wheel bearing was wrecked so replaced it.
Fitted new abs pass fr sensor, repaired loom to it also.
Greased all the abs connectors(1 to pass fr was corroded) & ecu plug.
Cleaned all 4 sensors & rings etc.
Removed the rust from hubs were sensors were fitted.
Adj rear sensor on 1 side with washer to make both rear gaps around 1-2mm.

This has now removed the abs fault from being displayed on the multi function display, but car still hasn't got dash light!


How do you turn it on???????

Had dash out, doesn't seen to be any bulbs that can be replaced.
 

·
Registered
Joined
·
4,506 Posts
if its not on...theres no fault...but if there is a fault with the abs and the light is not on your car may have suffered a surge..from the sounds of the harness issues, and cooked the led...but i highly doubt it as it will take more with it.

there is a thread regarding led replacement in the speed...please use the search button
 

·
Registered
Joined
·
28 Posts
Discussion Starter #5
Thanks for that, had clocks out but didn't want to damage them, least i know how to take dials off now to access led's.


Take it ABS smd led is red or orange? Same as the dash lights smd led's?


Reacon it must have blown due to a short in the loom to the multi-function display or the pass fr abs sensor.

There is no way abs light could have been turned off via diagnosists etc?

Was on with local scrappy earlier £50 for set of clocks, that crazyleds.co.uk is good value!


Was also great to find put that the button on dash dims lights, the other can reset the service light. Now sorted.
 

·
Registered
Joined
·
28 Posts
Discussion Starter #8
Over the moon,

ABS now sorted.

Got my SMD LED's to the door this morn for £2+ (bit cheaper than scrappy looking £50 for set of clocks!), when i opened dash found original ABS led had been removed! Soldered on new one, first time, everything works spot on.

Seems the guy I bought it off was trying a fast one by taking out light & disconnecting multi function display, all due to a wheel bearing, & sorting the sensors!

Now ready for MOT next month.

Thanks for the help.
 

·
Registered
Joined
·
4,506 Posts
glad you got it all sorted mate...i bet if it was the first time you saw SMD Leds u went "bloody hell!" haha easy enough though ey :thumb:
 

·
Registered
Joined
·
1,045 Posts
glad you got it sorted! but would the abs/esp fault not put you in limp mode?

mine did and took it to the dealer to see what was wrong and guy came back 20mins later you need a new abs pump so took his word and away i go to try and pick up a pump but lucky a mate of my brothers got new daig software and he wanted to see if my car came up on the daig and bingo it did and was rear drivers sensor was not the proper gap save me a few quid i tell you :)
 

·
Registered
Joined
·
4,506 Posts
glad you got it sorted! but would the abs/esp fault not put you in limp mode?

mine did and took it to the dealer to see what was wrong and guy came back 20mins later you need a new abs pump so took his word and away i go to try and pick up a pump but lucky a mate of my brothers got new daig software and he wanted to see if my car came up on the daig and bingo it did and was rear drivers sensor was not the proper gap save me a few quid i tell you :)
i dont think it will personally...i had a few abs faults when i had my 307 never put me in limp mode, it just switched of the abs so you were left with conventional brakes that would lock in an emergancy. but that was the sensors air gap was knackered due to carp behind the sensor...cannot say for the actual pump being knackered though and even still i dont think it will. in my opinion limp mode comes on for engine faults, could be wrong tho.
 
1 - 11 of 11 Posts
Top