Peugeot Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
64 Posts
Discussion Starter #1
Hi,
Just a quick post regarding an ABS warning and no Cruise control on a 2005 407 Diesel Salon. not my car but a friends vehicle.

Easy diagnosis using diagbox (ABS module) Right wheel sensor front and right wheel sensor rear faulty, fitted new sensors but with a couple of issues on the front the sensor was firmly jammed into the hole eventually had to drill a hole into it and put a wood screw then use a crow bar to force it out, sounds violent but I can tell you it was very stuck...(Tip there is a bracket next to the sensor with one bolt if you remove the bracket it makes life easier)
The rear came out much easier however the cable ran over the fuel tank to a connector under the seat next to the fuel tank neck/pump. We had to loosen the bolts holding the fuel tank to give enough space for the connector to pass, we used some wire attached to the old sensor then used it as a draw wire to pull the new one into place.

Cleared the codes with diagbox and the ABS module was all happy with no codes, we test drove the car, ABS was fixed, but the issue with the Cruise control and the over speed continued to show on the dash, we looked for a cause in the BSI / BCM however all looked fine we even tested the buttons using the interactive testing again all looked well. The error continued to show.

If you have this issue we found that if you drive the car for 2 klm after the speed sensors are replaced the Cruise control and the over speed warning start to work well and the dash warnings go away, without intervention.

Hope this helps the next person changing wheel sensors.

Cheers Tony
 

·
Registered
Joined
·
64 Posts
Discussion Starter #3
Hi did you check the brake switch? Faulty or not adjusted can do this.
Hi, We did check the switch thinking it might be high all the time, at the time we tested it we didn't see any issues, however I can see how this could cause a problem.

Cheers Tony
 
1 - 3 of 3 Posts
Top