Peugeot Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
170 Posts
Discussion Starter #1
Sorry to start another thread to something has probably been covered quite often already, I would use the search function but it doesn't accept words of 3 characters or less, which isn't all that helpful in this case.

I have had these lights going on/off during short journeys to and from work for about a week now, my car went in for a service yesterday and as I was having new discs on each corner I asked them to give the ABS sensors a clean.

This morning the light has come back on. I was wondering if someone could explain or point me in the right direction of something detailing how to clean the sensors to the required standard before I go any further and start reading fault codes and having things replaced...

Thanks.
 

·
Registered
Joined
·
4,506 Posts
my best bet would be the mounts the sensors sit on, there must be a 2mm air gap.

edit: the likely suspect will be the rear sensors...mine was always driver side rear...on reading other posts everyone also said rears
 

·
Registered
Joined
·
121 Posts
Now, I don't want to send you off on a dead end and I know the wheel sensors are usually the culprits BUT, my 307 SW ABS/ESP lights come on due to a dodgy signal from the brake switch! When they do come on it is ALWAYS as I touch the brakes. Cleaning the switch cleared the problem for a lot of months but it is back doing it again now and then. Fault code from my Maxidiag pointed me in the right direction!:thumb:
Phil:)
 

·
Registered
Joined
·
170 Posts
Discussion Starter #4
Thanks for the advice, it seems to come on independantly from when I am breaking so I think I will go with the sensors for now.
 
1 - 4 of 4 Posts
Top