Peugeot Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
My Peugeot 407 blows warm air intermittently. Sometimes it will blow icy cold and then warm or other times it will just blow warm air. I have had it regased and checked for leaks. The compressor clicks on but warm air is still produced. Does anyone know anything that would be causing this? Thanks for your help in advance!
 

·
Registered
Joined
·
30 Posts
I have a similar problem with my 207 CC, it only blows ambient temperature or hot air, no cold. I can't tell for sure if the compressor is activating but I don't think it is, I'm hoping it's a simple fuse. I''d love to see an Aircon expert answer!
 

·
Registered
Joined
·
1,094 Posts
I have a similar problem with my 207 CC, it only blows ambient temperature or hot air, no cold. I can't tell for sure if the compressor is activating but I don't think it is, I'm hoping it's a simple fuse. I''d love to see an Aircon expert answer!
You don't have a similar problem. Your car doesn't occasionally blow cold air.
My guess would be it has run out of refrigerant, plenty of shops in Perth could give you a proper diagnosis for a modest fee.

Roger.
 

·
Registered
Joined
·
30 Posts
Sorry Roger, I forgot to mention in my post, I had the gas checked and it was fine.

Is there a Planet owner in Perth WA I can buy beer for, or should I bite the bullet and get an AU$70-odd kit off eBay?
 

·
Registered
Joined
·
1,136 Posts
My Peugeot 407 blows warm air intermittently. Sometimes it will blow icy cold and then warm or other times it will just blow warm air. I have had it regased and checked for leaks. The compressor clicks on but warm air is still produced. Does anyone know anything that would be causing this? Thanks for your help in advance!
Check the flaps in the centre vent, the shafts break. Well documented problem, do a search on here/google.
 

·
Registered
Joined
·
1,136 Posts
I have a similar problem with my 207 CC, it only blows ambient temperature or hot air, no cold. I can't tell for sure if the compressor is activating but I don't think it is, I'm hoping it's a simple fuse. I''d love to see an Aircon expert answer!
System scans quite a few external sensors and will not work if found outside of expected readings. e.g. fans not working, temp sensor faulty. Scanning is the only 'reliable' way to help get to the bottom of the issue. But not just reading codes, live readings too. You may also be able to force the compressor to activate to check clutch control using PP2000, but this can also be checked relatively easily by providing an external power source to the compressor clutch.
 
1 - 7 of 7 Posts
Top