Peugeot Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Hi, i hope someone out there is able to help me with our problem we have.
we bought a 807 2003 2.0 hdi with 167,000 miles on clock from a friend, we knew ithad problems bu this didnt put us of, however we have mananged to sort everything about from the occasional loss of power. When we bought it, there was a new particulate filter fitted, we needed to have the additive oil tank filled up - which we did, however when driving it and for no reason, the car loses power and 'kangeroos' down the road, this goes on for about 2 - 3 minutes then it clears itself. It has been to a peugoet specialist and he drove it around for 50 miles with no problems at all, then on way home it does it again, he has plugged it in to his diagnostic equipment but nothing shows, he expaination was that the car was regenerating whilst being driven at a constant speed 60 mph, then we are going into traffic or slowing down and the car was confused and aborted the regeneration, so we got this loss or power, he told me when it happens put it into 3rd gear and put foot down to force the regeneration and it will be ok, we did try this and it did work, but is it really the correct answer????
please someone must know
thanks
lanney
 

·
Registered
Joined
·
8 Posts
Discussion Starter #3
There are no lights on dash to indicate a problem - so would anything show up at peugeot main dealer????
I have used car today and done about 30 miles round town and no probs, any suggestions???
 

·
Registered
Joined
·
8 Posts
Discussion Starter #5
We had decent fuel filter fitted and put 2 tanks od shell diesel in, but problem still there, the annoying thing is once the car has had its little hiccup its then a lovely car to drive!!!!
Any ideas anyone?????
Thanks
 

·
Registered
Joined
·
8 Posts
Discussion Starter #9
unfortunately, the diagnostic check came back with nothing, on reading forums, we came up with poss egr vavle due to it also being part of the exhaust emmissions bits, and also when the car plays up there is a very strong smell/fumes in cabin and throttle pedel goes stiff!
Any ideas?
 

·
Registered
Joined
·
8 Posts
Discussion Starter #12
Well, im happy to say we cured the problem!!!!

Our mechaninc blocked off the egr value!!!

Thanks for al suggestions
Lanney
 
1 - 12 of 12 Posts
Top