Peugeot Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
291 Posts
Discussion Starter #1
Hi All

I have a 2003 807 2.2 HDi.

I recently had to have the Turbo replaced due to it failing. Prior to this, I would occasionally get the "Unblock Diesel Filter" message on the screen relating to the DPF, a blast down the motorway in 4th would normally solve the error for a few months.

After having the Turbo replaced I got the message and took it for a blast, only to find that the message appeared again the next day, took it for another blast and the message disappeared for a couple of days and then came back. I decided to wire an LED into the heated mirror on the driver's side as I know the regen process turns them on for some reason, at least then I would know if the blast down the motorway was actually initiating a regen.

So, I've only had the LED fitted for a day, but the damn thing is almost never off, it even came on within a minute of starting the engine from cold, surely this can't correct. I would have thought a regen would only start when certain criteria is met, e.g. speed/revs, engine temp etc.

Does anyone have any clues as to why this might be? I'm still getting the message on screen too.

Cheers
 

·
Registered
Joined
·
291 Posts
Discussion Starter #2
Just realise that I have listed this in the "How To Guides" section, Admin - Please feel free to move it if required.
 

·
Registered
Joined
·
91 Posts
DPF Regen

Hi All



I have a 2003 807 2.2 HDi.



I recently had to have the Turbo replaced due to it failing. Prior to this, I would occasionally get the "Unblock Diesel Filter" message on the screen relating to the DPF, a blast down the motorway in 4th would normally solve the error for a few months.



After having the Turbo replaced I got the message and took it for a blast, only to find that the message appeared again the next day, took it for another blast and the message disappeared for a couple of days and then came back. I decided to wire an LED into the heated mirror on the driver's side as I know the regen process turns them on for some reason, at least then I would know if the blast down the motorway was actually initiating a regen.



So, I've only had the LED fitted for a day, but the damn thing is almost never off, it even came on within a minute of starting the engine from cold, surely this can't correct. I would have thought a regen would only start when certain criteria is met, e.g. speed/revs, engine temp etc.



Does anyone have any clues as to why this might be? I'm still getting the message on screen too.



Cheers


Check the Vacuum hoses from the DPF to the sensor. Mine did the same and I changed the hoses. That solved it. I dont know where the sensor is located on your car. Just follow the hoses.
 

·
Registered
Joined
·
291 Posts
Discussion Starter #4
Check the Vacuum hoses from the DPF to the sensor. Mine did the same and I changed the hoses. That solved it. I dont know where the sensor is located on your car. Just follow the hoses.
Thanks Barbaren, I'll check that when I'm off work at the weekend and report back with my findings.
 

·
Registered
Joined
·
11 Posts
Hi All

I have a 2003 807 2.2 HDi.

I recently had to have the Turbo replaced due to it failing. Prior to this, I would occasionally get the "Unblock Diesel Filter" message on the screen relating to the DPF, a blast down the motorway in 4th would normally solve the error for a few months.

After having the Turbo replaced I got the message and took it for a blast, only to find that the message appeared again the next day, took it for another blast and the message disappeared for a couple of days and then came back. I decided to wire an LED into the heated mirror on the driver's side as I know the regen process turns them on for some reason, at least then I would know if the blast down the motorway was actually initiating a regen.

So, I've only had the LED fitted for a day, but the damn thing is almost never off, it even came on within a minute of starting the engine from cold, surely this can't correct. I would have thought a regen would only start when certain criteria is met, e.g. speed/revs, engine temp etc.

Does anyone have any clues as to why this might be? I'm still getting the message on screen too.

Cheers
Peugeot 807 2.0 HDI 110 tuning options
 
1 - 5 of 5 Posts
Top