Peugeot Forums banner

1 - 16 of 16 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
Hi please can someone help, we have just purchased a 807 2.2 hdi, when we drive it the engine light comes on, and it goes into limp mode.

If we pull over turn off the car lock it then unlock it we have full power back but the light remains.
The fault code is

P0245 Intermittent fault. Turbo pressure, turbo pressure measured to high

What does this mean? is there a fix? do we need a new Turbo?

Sometimes if you turn the car off leave it over night then restart it in the morning then drive the light goes out, but then comes back on. We do not get anit pollution messages and the fluid has been re filled etc
 

·
Registered
Joined
·
533 Posts
I'm dragging this info from memories of a mate's 406. While I'm about it, see pic. I think it's around number 7...(?) (If that's your set up.) Also check all the hoses, etc. for collapse, leaks, splits, or looseness.
 

Attachments

·
Registered
Joined
·
11 Posts
Discussion Starter #5
thanks joe for the reply, have contacted peugeot, £95 +vat for part, book in at a specialist, for code read, he seems pritty sure it's a vac/pipe leak.

will keep everyone posted on outcome.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #6
smoke test

Hi Had the specialist do a smoke test, no evidence of a boost leak from the hoses/intercooler, they thought one of the 2 valves at the bottom of the scuttle panel where to blame so changed the faulty one.

Car seemed ok but again the light came on the following day have booked it in again with garage.

Any more ideas???:(
 

·
Registered
Joined
·
134 Posts
fault

hi,,,make sure the vacuum swirl capsule rod is intact and operating correctly.

toddy
 

·
Registered
Joined
·
11 Posts
Discussion Starter #8
light out

engine light now out, I took the out the Large actuator housing which conects to the intake manifold. one of the butterfly flaps was/is sticky.

I cleaned it out with brake cleaner then sprayd wd40 in it. dry'd it and re assembled, after to rev's the engine light went out. and has stayed out.

Hopefully this is the problem, if it stays out i will buy a new unit around £100.
thanks for everyones help.:)
 

·
Registered
Joined
·
11 Posts
Discussion Starter #9
up date

:confused: Dam light back on after 2 miles, and in limp mode. got it home took the actuator off again and the bottom flap is sticky and as a lot of side to side movement.

But it all back together and the light has gone out???? this surely must be the problem?
 

·
Registered
Joined
·
1 Posts
P0245 Permanent fault. Turbo pressure, turbo pressure measured to high

I have solved this issue controlling the 3 electromangetic valve tubes, right below the windscreen brushes.
I had to dismount the plascic covers of the 2.2 16V engine for easy access to the tubes.

2 of the valves had very loosy tubes. The tube material is too old and vacuum is not enough to control well the Turbo.

considering the easy access, this should be controlled FIRST when you get the P0245 error

Good luck
Martin
Belgrade
 

·
Registered
Joined
·
11 Posts
Discussion Starter #12
Problem solved

The problem in the end was down to a slightly BENT plastic actuactor arm, think the engine may have been out before and done that when putting back in.
 

·
Registered
Joined
·
1 Posts
Could you describe exactly what you did to the car, the image part that you replaced would be great? Thank you in advance!
 
1 - 16 of 16 Posts
Top