Peugeot Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hello Everyone

I bought an 806 Quicksilver HDi back in the summer. It's been excellent. Lugging a large number of people/dogs/bikes to the west coast of Scotland and down to south Wales.

Anyhow, the heater blower didn't work so I fixed that but the heater never seemed to get very hot. Now winter is here - it's useless. It'll defrost the bottom two inches of the windscreen but no more.

I've read up on this problem and checked the following:

The thermostat seems to work as the top hose stays cold until the engine heats up - then warms quickly.

The Webasto heater is working because the exit pipe heats really quickly - more so than the rest of the system.

The pipes that go through the bulkhead are both quite hot.

I've read that there's a motorised flap that sticks but I've never found any info on how to access this?

The car has climate control with the digital panel - could this be faulty?

Any help would be appreciated as the car is undriveable in the current weather.

Thanks ;)
 

·
Registered
Joined
·
1,054 Posts
Our Synergie was Motability so never fiddled with it, could it's pollen filter be blocked, not sure if it has one but 807 does. Could the ducting to the matrix be blocked with leaves? Can you select 'screen' on the panel and does it blow under it?
Sorry answer not very helpful.
 

·
Registered
Joined
·
192 Posts
There are a couple of stepper motors in the heating system, from memory they're both on the passenger side behind the glovebox, but well buried.
Does the heater blow in other directions ok? i.e. facing vents and footwells, if so I'd try switching it in different directions to get the motor working, if that fails, looks like you're going digging into the depths of the cars wiring. :-(
 

·
Registered
Joined
·
6 Posts
Discussion Starter #4
Thanks chaps.

Yeah pollen filters are clear.

The air does come out of the correct vents when you select the different options. Is there a bleed valve on the matrix I could try before delving behind the dashboard?

I haven't been able to source any manuals that show me the whole system. Are there any available?
 

·
Registered
Joined
·
192 Posts
So is the air a constant force and temperature through all the different vents? if so it sounds like your matrix could be bunged up or the inlet flap isn't opening somewhere.

Not seen any manuals for these cars and far as I know no bleed screw for the matrix, but as you say, both pipes are hot enough where they pass through the bulkhead so my guess is it's an airflow problem rather than water prob.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #6
Yeah - temp is the same. Luke warm. Air seems to be constant force though perhaps not as powerful as one might expect with the blower on full.

Based on the fact that both pipes going to/from the matrix are hot would indicate that there's a flap not opening, would it not?

I guess the problem is finding the flap.............
 

·
Registered
Joined
·
192 Posts
Best way is to remove totally the lower panel that runs right round under the gear stick and glovebox and pedals, then access is pretty good.
 
1 - 7 of 7 Posts
Top