Peugeot Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Dear all

New to this forum, so Hi!

Recently I had problems with my 806 and it just would not start at all

After months of trouble shooting we changed the diesel pump and removed the electrics in the pump so NO immobiliser problems in the future......hooray!!

Now car starts fine when cold, but when warm it takes a lot longer to fire than it should do?

I struggled to find a decent mechanic who would replace the pump and he mentioned it could be the timing?

Any help would be appreciated

Thanks
 

·
Registered
Joined
·
192 Posts
Could be timing, but if it starts ok from cold and sounds ok I doubt it will be. Could even be low compression, whats the mileage?
 

·
Registered
Joined
·
192 Posts
If it is low compression I'm afriad it major open heart surgery for your engine :-(

From warm, when it starts, what colour is the exhaust smoke?
 

·
Registered
Joined
·
14,941 Posts
Could also be a weak starter as sometimes when they get hot they cant crank as well as oil gets inside them over time and this coats everything slowing them down.

Try parking on a hill when hot and see if it starts easily rolling down hill and bump starting
 

·
Registered
Joined
·
19 Posts
Hi guys

Not noticed the smoke but will look next time citrail

No hills in Essex reliable :)

So it's piston rings etc?

What's this going to cost approximately?

Car is old, the usual story on these I reckon, car runs so well, not a blip in 600 miles after the pump was fitted??

Thanks so much
 
1 - 6 of 6 Posts
Top