Peugeot Forums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
79 Posts
Discussion Starter · #1 ·
Here are my on going issues with the car - I wish I could solve them as I'm on the verge of selling it !!

First 6 months of ownership were good. Car was working without a problem.

Then for some reason, the gremlins moved in: here's the list:

- Colour screen does what it wants. Comes on and works for 1 minute, sometimes 5 minutes, sometimes (vary rarely) works for a whole journey. But then after that, it turns itself off, rendering the audio system and telephone useless as it locks up the controls and whatever item I'm using at that time is what it's locked into for the journey.

It's been on PSA Diag / Peugeot Planet and no errors were found. I was recommended to get the system replaced for £1500 !!!! :0

I did buy a new screen, cheaply - but the problem is the SAME.

Sometimes when the screen plays up it goes on and off. Then before finally tuning off permanently that journey it says "WARNING: Reprogramming Sequence" Then an error code comes up - "Error 0x00005555"

Though on New Years Day it worked with out issue for 3 days !!. Then the day after it worked again for a further 7 days !! Now today it's back to the same as described above.

I'm convinced it's a software problem - but no matter how many times I install the blooming update CD the problem persists!!!!!!!!

ARRRRRRRRRRRRRRRRRRRRRRRRR


AND -

- Parking sensors mysteriously stopped working - they just emit a long beep. Had this diagnosed on the peugeot diag, but no errors returned except for the sensors apparently reading that an object directly in front of them is 100's of feet away.

Any help with these and I'll be happy happy happy !!!!


Tris
 

·
Registered
Joined
·
1,002 Posts
Tristan.. cheif, that sounds to be the Display ECU... its behind the glove box.. you would need to replace that.. any other car with the color satnav will do.. part number is not written on it.. its the serial number...
 

·
Registered
Joined
·
1,002 Posts
davidg6529 said:
I have an identical problem with the display.
How to I get to this ECU?
its behind your glove compartment, take it out and you will find it there.. its a box like thing with connector at one end..
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top