Peugeot Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
My 57 reg 407 went in for a major annual service in November and when it was returned it felt sluggish to start. Over the next couple of weeks it got progressively worse until it finally needed a push to start.

Took it in to the garage where they did computer diagnostics and informed me it needed a new fuel rail which they replaced along with another fuel filter which had just been replaced during the service. It once again felt more sluggish to start but it didn't need a push to leave the garage and I assumed the problem had been fixed. The next morning it wouldn't start without a push again so I took it straight back to the garage. After a couple of days they said they had to take it to another garage to hook it up to another computer to get a read out. This time it was diagnosed as needing a fuel injector and the air mass replacing. So once again paid for the work to be carried out (fuel filter replaced again). On collection this time noticed it was still more sluggish to start than it used to be before it was serviced and that the power steering fluid reservoir was near empty even though it had just been filled during the service.

So had it back for 3 days and it was still more reluctant to start than it had previously been but this morning it needed a push start again!

I'm reluctant to keep paying for work to be done that doesn't fix the problem.

Any advice would be gratefully accepted.

Thanks.
 
C

·
Guest
Joined
·
0 Posts
Different garage?

How is your battery condition ?

contact someone on here to get it on Planet

http://www.peugeotforums.com/forums/general-discussion-2/how-contact-member-peugeot-planet-diagnostic-28190/

Updated Planet Map

http://api.viglink.com/api/click?format=go&key=1357cdd94749dd9cc41c76513a9522b2&loc=http://www.peugeotforums.com/forums/peugeotforums-com-suggestions-help-49/time-new-peugeot-planet-owners-map-31112/index3.html&v=1&libId=48296653-2e91-4316-8ce8-cd3bdc5d2ff5&out=https://maps.google.com/maps/ms?msid=214397633218647067111.0004dc947e5c1752ca0a2&msa=0&ll=54.521081,-1.647949&spn=10.175332,28.54248&ref=http://www.google.com/cse?cx=partner-pub-7865546952023728%3A2054226937&cof=FORID%3A11&ie=UTF-8&q=time+for+a+new&sa=Search&siteurl=www.peugeotforums.com%2Fforums%2Fgeneral-discussion-2%2Fhow-contact-member-peugeot-planet-diagnostic-28190%2F&ref=www.google.com%2Fcse%3Fcx%3Dpartner-pub-7865546952023728%253A2054226937%26cof%3DFORID%253A11%26ie%3DUTF-8%26q%3Dhow%2Bto%2Bcontact%26sa%3DSearch%26siteurl%3Dwww.peugeotforums.com%252F%26ref%3D%26ss%3D3215j1711209j14%26ad%3Dn9%26num%3D10%26rurl%3Dhttp%253A%252F%252Fwww.peugeotforums.com%252Fforums%252Fgtsearch.php%253Fcx%253Dpartner-pub-7865546952023728%25253A2054226937%2526cof%253DFORID%25253A11%2526ie%253DUTF-8%2526q%253Dhow%252Bto%252Bcontact%2526sa%253DSearch%2526siteurl%253Dwww.peugeotforums.com%25252F%2526ref%253D%2526ss%253D3215j1711209j14&ss=2024j365144j14&ad=n9&num=10&rurl=http%3A%2F%2Fwww.peugeotforums.com%2Fforums%2Fgtsearch.php%3Fcx%3Dpartner-pub-7865546952023728%253A2054226937%26cof%3DFORID%253A11%26ie%3DUTF-8%26q%3Dtime%2Bfor%2Ba%2Bnew%26sa%3DSearch%26siteurl%3Dwww.peugeotforums.com%252Fforums%252Fgeneral-discussion-2%252Fhow-contact-member-peugeot-planet-diagnostic-28190%252F%26ref%3Dwww.google.com%252Fcse%253Fcx%253Dpartner-pub-7865546952023728%25253A2054226937%2526cof%253DFORID%25253A11%2526ie%253DUTF-8%2526q%253Dhow%252Bto%252Bcontact%2526sa%253DSearch%2526siteurl%253Dwww.peugeotforums.com%25252F%2526ref%253D%2526ss%253D3215j1711209j14%2526ad%253Dn9%2526num%253D10%2526rurl%253Dhttp%25253A%25252F%25252Fwww.peugeotforums.com%25252Fforums%25252Fgtsearch.php%25253Fcx%25253Dpartner-pub-7865546952023728%2525253A2054226937%252526cof%25253DFORID%2525253A11%252526ie%25253DUTF-8%252526q%25253Dhow%25252Bto%25252Bcontact%252526sa%25253DSearch%252526siteurl%25253Dwww.peugeotforums.com%2525252F%252526ref%25253D%252526ss%25253D3215j1711209j14%26ss%3D2024j365144j14&title=Time for a new Peugeot Planet owner's map? - Page 3 - Peugeot Forums&txt=https://maps.google.com/maps/ms?msid...75332,28.54248&jsonp=vglnk_jsonp_13895264546839
 
C

·
Guest
Joined
·
0 Posts
Sounds to me they don't know what's wrong and are throwing parts at it.

Use another garage or get a diagnostic scan as suggested above by someone who owns planet.

Check fuel filter bowl isn't damaged or leaking air seen one recently that had damage to fuel line connections that was letting so much air in it wouldn't start.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
Sounds to me they don't know what's wrong and are throwing parts at it.

Use another garage or get a diagnostic scan as suggested above by someone who owns planet.

Check fuel filter bowl isn't damaged or leaking air seen one recently that had damage to fuel line connections that was letting so much air in it wouldn't start.
That sounds very feasible, since it all started after a service, which I assume could have caused this.
 
C

·
Guest
Joined
·
0 Posts
Before trying to start it lift bonnet and pump the priming bulb next to fuel filter bowl til it's hard then try starting it, to see if it makes any difference.
 
1 - 8 of 8 Posts
Top