Peugeot Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Hi, I have had this car for over a year and it has always had this problem however over the last few months it has got worse and worse. It’s now at the point where I don’t have a clue where the biting point is and pretty much jolt around everywhere. Once up to speed it is absolutely fine (no fluctuations) it’s just when crawling in traffic or pulling away.

Any thoughts?

Any help offered is much appreciated.
 

·
Registered
Joined
·
169 Posts
There's more than one variant of the 1.4 engine.

If it's the 1.4Vti my money would be on an air leak between the throttle body and the inlet manifold or clogged filters on the solenoid valves.

Please clarify what engine variant, or give us the VIN and we can look it up, before we go any further.

Regards,
Ivor
 

·
Registered
Joined
·
169 Posts
You have the 1.4 i 16v 90 engine.

Possible leaking throttle body to inlet manifold seal (item No.2) here:



Possible clogged filter in solenoid valve (or faulty/sticking valve) immediately to the left of the coil pack between the two camshaft covers on the top of the engine. Single bolt holds it in. A failed valve would usually throw up a fault code though.

Another user - JONCON - posted a photo of his recently in another thread... (thank you John, hope you don't mind me using it here)

 

·
Moderator
Joined
·
6,587 Posts
When were the spark plugs last changed and are you sure its not light clutch slip
 
  • Like
Reactions: Equinox

·
Registered
Joined
·
4 Posts
Discussion Starter #7
I’ll try both thanks - is the solenoid you refer to an oil pressure switch?

Spark plugs were changed May last year. Could be clutch I suppose. I’ll try the inlet seal and solenoid before going down that route. Thanks again.
 
1 - 8 of 8 Posts
Top