Peugeot Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
horns not working checked fuse 5 in engine bay (ok) checked for voltage at horns ( none) removed airbag unit and checked for voltage only 5.5 volts to ground ,cleaned switch contacts,
question, is this voltage correct ?
where is the relay that controls horns ( according to haines elec diag) ?
if 5.5 volts correct would this imply the loss of the negative
would be grateful for any advice
 

·
Registered
Joined
·
15,377 Posts
Horn is wired with a power and earth via a relay

The horn section of the steering earths when you press the horn this switches a relay which then switches the power to the actual horn so from your description it sounds like your issue as at the steering column if your voltage readings are correct as if horn push is not working you wont get power at horn connections.
 

·
Registered
Joined
·
112 Posts
when i had horn problem it turned out that some one had messed with it before, the airbag unit wasnt correctly refitted and clipped together properly which was enough to stop the horn contacts meeting behind it,, took me a year and fitting a remote control horn button before i finally sorted airbag out and got horn working properly.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #4
Hi thanks for that info do you know where the relay is located as its not in the engine bay fuse box
regards howard
 

·
Registered
Joined
·
10 Posts
Discussion Starter #5
Hi thanks for info I have had the airbag off and cleaned the contacts and shorted the switching out to no avail do you know if I should have 12 volts as I have only got 5.5 volts and as its switching to the negative could this 5.5 volts be due to volt drop through relay etc
regards howard
 
1 - 5 of 5 Posts
Top