Peugeot Forums banner
1 - 17 of 17 Posts

· Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
Hi all - newbie here! I bought a 508 SW GT about two months ago and absolutely love it. I was driving home from work earlier today and I indicated to turn left and an error popped up - check indicator bulbs, followed by check fog lamp bulbs.... I now have no front fog lights and no front indicators. I've tried disconnecting the battery for 15 mins but that made no difference. I've also tried using the FAPLite app for Android but it shows 0 errors. Does anyone here know if the fogs/front indicators share a fuse, and if so what one? Or whatever else it could possibly be? Thanks Gareth
 

· Registered
Joined
·
9 Posts
Discussion Starter · #7 ·
Well it's decided to stop working again so guessing it could well be the battery. I'm not sure how old it is but has always seemed ok, I do about 60 miles a day Monday to Friday as well so gets a good charge. Ive just been out and checked all the bulbs too and they're fine
 

· Registered
Joined
·
149 Posts
Well it's decided to stop working again so guessing it could well be the battery. I'm not sure how old it is but has always seemed ok, I do about 60 miles a day Monday to Friday as well so gets a good charge. Ive just been out and checked all the bulbs too and they're fine
Halfords should be able to do a test on your battery for free...

http://www.halfordsautocentres.com/car-batteries/free-battery-check

You don't need to buy the battery from them so worth finding out what you have and the web prices of them just in case..
 

· Registered
Joined
·
9 Posts
Discussion Starter · #9 ·
That's the next step I think, luckily my brother in law works at a Halfords so I'll ask him to do a test and go from there. Battery is sounding more likely as I've just noticed the electric mirrors intermittently don't open when's I unlock it
 

· Registered
Joined
·
2,540 Posts
That's the next step I think, luckily my brother in law works at a Halfords so I'll ask him to do a test and go from there. Battery is sounding more likely as I've just noticed the electric mirrors intermittently don't open when's I unlock it
It isn't always the battery at end-of-life. Also get him to check the alternator output - you are looking for at least 14 V.
 

· Registered
Joined
·
9 Posts
Discussion Starter · #13 ·
Battery seems ok, diagnostics show a fault in one of the engine relays. Weirdly when looking at other forums others have experienced issues with the mirrors too and also starting problems linked to relays
 

· Registered
Joined
·
502 Posts
do you know how much is BSI module if it was you who need to pay
 
1 - 17 of 17 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top