Peugeot Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
My wipers starrted acting up the other day. Passenger side (right side) started jerking around and finally stopped in the "straight-up" position. My driver side wiper then started doing the fail-safe 25% wipe. After reading a lot about the problem I figured that if I got hold of a second-hand wiper motor I would not need to get it coded to the car. As it was the passenger side wiper who stopped I found a second-hand one and installed it. Nothing happened. I did the BSI reset, but that did nothing.
So, the question is, can it be the driver side (left side) motor that is faulty? Even when it is the only one still functioning? Should I try to get the other wiper motor from the same car or does that not matter?

I also read something about changing a chip in the wiper. Done a lot of soldering so maybe try that one also, but I cant find the post? Anyone?
 

·
Moderator
Joined
·
7,854 Posts
Normally if one motor fails the other motor will go into safe mode and have a limited wipe to prevent them clashing. They sync to each other using CAN/LIN network. Have you checked that the fuse for the motors normally F6 40 Amp fuse in the engine bay fuse box.

Does the second hand motor have the same part no as there are a few different motors fitted dependent on year. I have also heard of a few people who did need to calibrate the wipers using diagbox
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
I have not yet checked the part numbers. The driver side wiper also stopped working today so I guess it is also part of the problem so I ordered this one also from the same car. Hopefully it will arrive early next week. The Peugeot place would like £1150 for the job so hopefully I can get it fixed myself.The fuses are ok by the way. If I need to calibrate them I have to find a Diagbox guy nearby since I dont have it myself yet :)
 
1 - 4 of 4 Posts
Top