Peugeot Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
65 Posts
Discussion Starter #1
Hi.Can any one tell me why my N/S wiper just starts on its own. Even when the car is not in use,just parked there.Im fed up with buying new wiper blades. As when it starts it catches the O/s one and snaps off. :( Cheers Steve.
 
D

·
Guest
Joined
·
0 Posts
Get a diagnostic check done on master wiper motor ecu. You'll most likely need two wiper motors. Not a hugely common fault on 407 but common on c5.

Sent from my GT-S5690
 

·
Registered
Joined
·
65 Posts
Discussion Starter #3
Thanks for the quick reply. Will i need both wiper motors,even though its only the N/S that is playing up.Cheers Steve.
 

·
Registered
Joined
·
65 Posts
Discussion Starter #4
Forgot to say.It only does it about every couple of months. It can be just parked up and the N/S one will just do one sweep just once. But enough to snap it on the O/S one. Cheers Steve.
 

·
Moderator
Joined
·
5,071 Posts
my last 407 (RIP) used to do this occasionally only on unlock tho and only about a dozen times or so in the 6 year i had it, never really bothered me BUT i did carry a spare blade in the boot just incase :rolleyes: which when i started doing that it never snapped another, just used to get its (knickers) arms in a twist sometimes
 

·
Registered
Joined
·
65 Posts
Discussion Starter #6
my last 407 (RIP) used to do this occasionally only on unlock tho and only about a dozen times or so in the 6 year i had it, never really bothered me BUT i did carry a spare blade in the boot just incase :rolleyes: which when i started doing that it never snapped another, just used to get its (knickers) arms in a twist sometimes
What with my bluetooth activity and my wiper problem. And then this morning my rear parking sensors decided not to work. I love my 407:rolleyes:
 

·
Registered
Joined
·
1,947 Posts
What with my bluetooth activity and my wiper problem. And then this morning my rear parking sensors decided not to work. I love my 407:rolleyes:
I bet you love it more than I love mine.
All mine does for 20 bloody minutes first things is churn and churn till it finally decides to fire, then it runs like a lumpy bag of turd!
Felt like I was astride a kangaroo earlier. It's seriously starting to test my patience.
 

·
Registered
Joined
·
65 Posts
Discussion Starter #8
Getting back to my wiper problem. I read a thread on here the other day saying it was down to a bad earth. But i cant find the thread now. Can anyone shed any light on it.Cheers Steve.
 

·
Registered
Joined
·
2 Posts
I have exactly the same issue with my 407. I have learnt that it has the propensity to do it when the battery is in a state of discharge after periods of in use or repair.
Its just a Peugeot 407 foibles and you learn to live with it. Carry a bootful of spare blades and learn to love it.
 

·
Registered
Joined
·
1,384 Posts
I remember when the 407 SW came out a few of the service managers at the company I work for picked them as there company car.

After about a year whenever the service managers got together for a meeting they would end up comparing notes on what has gone wrong with there 407 since they had it - the lists where getting longer every meeting until eventually the 407s all went back to the leasing company.

FWIW all the service managers now are given Toyota Hybrids to drive.
 
1 - 11 of 11 Posts
Top