Peugeot Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi,i've just purchased a 2007 407 2.0hdi with approx 145k.Car drives fine but have noticed that the temp gauge would rise to about 70 and then would start to decrease and then rise to about 70 again.If I park the car up and leave it ticking over the gauge will rise slowly to almost the 90 mark,worth noting is the fuel efficiency too as I filled the car to approx the first nick past halfway,I now am at the first nick past the red and have only covered approx 230 miles
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Ordered a temp sensor yesterday and also going to stick a thermostat in while i'm in there,hopefully that will cure it as I dont want to give up yet on the car.Would the temp sensor make it use more fuel too as I would of expected more miles on this car than my old car which was a 3.0 tid Saab 95.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
Purchased temp sensor and stat but mechanic can't fit until the next week or two however theres a guy local to me who works a bit with motors so I left the car down with him.He removed the air box to get at the housing for the stat and has discovered also that the temp sensor supplied from the local motor factors is the wrong one.He says the one I need just pushes into the housing but the one I have screws in.Is it handier or cheaper to just buy a housing complete with stat and temp sensor if this is possible?
 
1 - 5 of 5 Posts
Top