Peugeot Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hi Guys !

I am writing from Poland,sorry for my language.

I have 2009 2.0 hdi 407 with Automatic 6 gearbox (AM6 I assume)

Yesterday when I was driving on higway around 170 kph car suddenly switched off the engine !!

I pulled over car immediately and I see on dashboard "Please put gearbox to Park Position"

After few minutes I switched off/on the car and it works/goes normally

Naturally I was afraid to go around 170 kph to test again but I am not sure If I can have same problem in the future.I am carrying my family in the car so it is extremely dangerous situation on highway.

I dont have any problems with any gears so far,it is all so smooth but how car can switch off without warning on high speed,we could be dead or cause others to be dead.

Please advise if someone has clue ? whether it is because of Automatic gearbox,crankshaft or some other things ?

Temperature of the car was ok around 90 degree,no overheating.

Thanks for your help.
 

·
Registered
Joined
·
15,376 Posts
Put in park position was BECAUSE engine cut out as the gearbox ecu wants to see park when stopped thats not the problem merely a symptom.

407 fuseboxes can cause issues cutting the engine randomly i have seen this a few times now speed is irrelevant it will just do it randomly you just restart and its fine if it keeps doing it check diagnostics if it says something to do with sudden power cuts then its most likely the fusebox.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
Put in park position was BECAUSE engine cut out as the gearbox ecu wants to see park when stopped thats not the problem merely a symptom.

407 fuseboxes can cause issues cutting the engine randomly i have seen this a few times now speed is irrelevant it will just do it randomly you just restart and its fine if it keeps doing it check diagnostics if it says something to do with sudden power cuts then its most likely the fusebox.
Thanks for the info,any tips on fusebox ? which fuse should be checked or replaced ?

I assume speed might be relevant in my case,I am strongly suspecting on automatic gearbox,because I never had that problem in low speed city driving,first time i gone up to 170kph,then car gets shaky,felt like car wants to go and something is stopping car like rev limiter feeling and gear gone to neutral and engine cut off.
 

·
Registered
Joined
·
15,376 Posts
I said fusebox not fuse the fault is INSIDE the fusebox.

Gearbox is not going to cut the engine.

When the engine cuts out the gear WILL seem to go to neutral i doubt its the box the shaking you describe may have contributed to the fusebox cutting off its hard to say but my guess is the fusebox but i would not be replacing it after 1 occurrence it needs to happen a few times.

Ones i fixed were manuals same problem though engine cut out mainly at speed
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
I said fusebox not fuse the fault is INSIDE the fusebox.

Gearbox is not going to cut the engine.

When the engine cuts out the gear WILL seem to go to neutral i doubt its the box the shaking you describe may have contributed to the fusebox cutting off its hard to say but my guess is the fusebox but i would not be replacing it after 1 occurrence it needs to happen a few times.

Ones i fixed were manuals same problem though engine cut out mainly at speed
I got your point,thank you,good to know it is not gearbox.
Hope it does not repeat though.

I had overheating issues , took mechanic,he said Radiator Fan is not working so they replaced fan with original parts (costed 300 dolars) Just changed radiator fan yesterday because it was not working and overheating issue solved then bom,vehicle stoped middle of the highway.

Guess my adventure will Peugeot will end soon.

Thanks again for your help.
 

·
Registered
Joined
·
1 Posts
Dials going to 0 with intermittent electrical fault

My Peugeot 407 has had an intermittent fault that is driving us crazy! I can see from the thread that the beeping and airbag/pretensioner seatbelt fault could be due to wiring under the seats. Ours is worse because it will beep and then all the dials go to 0. After 5seconds they all come back. This will keep happening. Sometimes the centre column with the radio and satnav will go off too then come back on. It is concerning but no one has worked out what is wrong! It also cycles through the faults in alphabetical order then says assistance call downgraded or engine fault repair needed. Next time we switch it on all faults are clear and it will be fine for a few days. Any ideas what we can suggest to the garage or fix ourselves?:(:(
 
1 - 6 of 6 Posts
Top