Peugeot Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
Hi, i think my outside temperature sensor doesnt work as im getting no reading on my display,so if anyone can tell me where it is and how to remove/replace it,it would be appreciated.just recently bought the car and it seems fine except for one or two little niggles etc bootlid "o" button and telephone sim card,other than that all seems ok at the moment. so any help will be welcome....thanks in advance:)
 
J

·
Guest
Joined
·
0 Posts
The sensor is in the driver's door mirror - a little black plastic dome sticking out the bottom of the mirror casing :thumb:
 

·
Registered
Joined
·
1,912 Posts
The boot button problem will be broken wires as they enter or leave the rubber gaitor from the boot, or the button itself needing some diy adjustment. Good luck auldyin
 

·
Registered
Joined
·
11 Posts
Discussion Starter #5
thanks for the replys guys,jm i take it i can remove the rear of the mirror cover and gain access to the sensor from there,i assume because there is no reading on my display that the sensor is at fault or is there possibly another cause or is it a common fault.....sterion bent the back of the button about a little bit and now it works perfect...:thumb:
 

·
Registered
Joined
·
1,912 Posts
auldyin, get some boot card plastic fixing clips because you will break several removing it to get to the switch.
Wow nearly forgot is boot locking enabled, i believe its in the mfd ecu entered directly, not with planet.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #7
Cheers sterion,i did break a couple of clips but just bent the switch and twisted it a little and now it works perfect,so just need to buy a couple of new clips then try the temp sensor hopefully i dont break anything on the wing mirror.:thumb:
 

·
Registered
Joined
·
11 Posts
Discussion Starter #9
Magma, im getting no reading on the display it just show _ _c or something like that... thanks
 

·
Moderator
Joined
·
5,040 Posts
this might help

 

·
Registered
Joined
·
11 Posts
Discussion Starter #13
My temp switch fault was actually an expensive fix,it turns out there is a control unit in the passenger side door that controls the wing mirror,electric windows and such and in my car it seems water had got into the control unit and corroded the plug,i had to replace this as my wing mirror wouldnt fold in,so i bought a new mirror thinking thats it sorted only to find out the control unit was gubbed and i had to fork out £220 for the control unit to be fitted.but on the bright side my mirror is now fully working and my temp sensor is working too....:thumb:
 
1 - 13 of 13 Posts
Top