Peugeot Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
hi, my 2007 407 coupe has started to give intermittent warning notices at start up for the EPS, ancillary lighting, self adjusting lighting and cruise control and then do not work. After a while this may correct itself OR stays off for a couple days and then works again??
Any ideas please?
 
C

·
Guest
Joined
·
0 Posts
Possibly dodgy earth plenty of info here about that one.

Abs/ESP could be duff abs sensor but I'd guess at faulty brake switch.

If earth and brake switch which you can do yourself it'll cost you £10-20.:)
 

·
Registered
Joined
·
127 Posts
Hi Steve

As David say's, get it scanned and see what fault codes are pulled off. It will give people a good idea as to what may be wrong. ( BSI, sensors, earth etc)

Can you keep this thread updated as to how it goes and outcome? I have a 407 coupe too so would be interesting to see what the prognosis is.

In the mean time - anyone know where all the "problem " earth points are on the coupe? I could do with checking mine. :thumb:
 

·
Registered
Joined
·
4 Posts
Discussion Starter #8
Honey l'm home

Hi all
Been away so haven't replied. Disconnected the battery and this seems to have rectified that problem. Will keep you posted.
On another note my parking sensors have packed up, when I put it in reverse warning light says 'parking sensors faulty' any ideas on that one??
 
D

·
Guest
Joined
·
0 Posts
Hi all
Been away so haven't replied. Disconnected the battery and this seems to have rectified that problem. Will keep you posted.
On another note my parking sensors have packed up, when I put it in reverse warning light says 'parking sensors faulty' any ideas on that one??
Again for this MAJOR fault get a diagnostic check on the parking aid ecu. Post up the faults.

Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
13 Posts
hi, my 2007 407 coupe has started to give intermittent warning notices at start up for the EPS, ancillary lighting, self adjusting lighting and cruise control and then do not work. After a while this may correct itself OR stays off for a couple days and then works again??
Any ideas please?
I had same issue and it was the brake light switch, the fault would go away until braking hard as it was sticking. Be aware that when the fault occurs my brake lights stopped working as the switch wasn't disengaging, may not be the case for you, but double check if it does reoccur and make sure your brake lights aren't failing to come on.
 
1 - 10 of 10 Posts
Top