Peugeot Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter #1
I have some problems with my wifes 407 2,2 16V 2004.

I cannot by any means get the park assist to show up on the MFD.
I can without any problems connect to the ECU with Diagbox, but it Always reports CANBus problems.

I have replaced the ECU with one from a smached car, since the original was drowned.
The replacement ECY had an identical sticker as the original, all numbers were the same.

I have also replaced the MFD, since it was faulty, now it shows up as an "Unknown Computer" (Translated from Swedish).
When I connect to it with DiagBox, I have two options, one is called type "C" the other one type "C Colour"

If I try the first one, nothing happens, just says communicating.
When I trie the other one, I can get into it.

So, what am I doing wrong, and how do I get the park-assist ECU to show up in the display.

My last question is, the MFD in the center of the dash is loosing pixels, when it gets warm, guess it is a similar problem as the larger MFD, but where can I get a pelacement display.
I have found someone on ebay, but the need to know the length of the FFC-Cable, and I dont really want to pick the dash appart for measuring the FFC.
 

·
Registered
Joined
·
14,288 Posts
Hi your not clear you say you replaced the ecu but i assume you mean ecu set IE bsi too if so it may be the car it was removed from did not have parking assist
 

·
Registered
Joined
·
23 Posts
Discussion Starter #5
Hi your not clear you say you replaced the ecu but i assume you mean ecu set IE bsi too if so it may be the car it was removed from did not have parking assist
I replaced the Park Assist ECU, with an identical item from the scrapyard.
 

·
Registered
Joined
·
23 Posts
Discussion Starter #7
Well, I can actually communicate with it (with diagbox) and I can program/configure the ECU, however I cannot figure out on how to get it to the display, and why it shows Canbus errors.
 

·
Registered
Joined
·
14,288 Posts
If the display has been changed it would need configured to suit too as there are many versions of software etc i recon your real issue is the display now not the parking sensor

If the display is not from a 407 it will work but it wont have the correct options even then there are so many variants on the newer displays the config needs to be correct too.

I fitted an RD45 head unit to my 2009 207 and i went through at least 6 displays before i got 1 that done everything i needed they all worked but i wanted 1 that showed tracks on usb stick and also worked with the built in bluetooth for my phone most only done some of the functions
 
1 - 9 of 9 Posts
Top