Peugeot Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
73 Posts
Discussion Starter #1
Car: 1999 406 Estate 2.1 TD

Problem: Heater won't work

How it happened:
Well, I left the dog tied up in the back on the left hand side. Came back an hour later and noticed first that the heater blower motor didn't turn on and the radio was dead and there was an odd smell in the car. When I opened the boot I saw that dog had ripped out the boot light and ate it leaving the wires stripped and bare and she had torn off the storage compartment cover exposing a mass of wires.

What I did:
I secured the boot lamp wires so they wouldn't short until I can sort that out then checked all the fuses under the dash and found one 10A fuse blown. Replaced that and now the radio works.
Heater motor still dead. Checked fuses under bonnet, all OK.

Help I need:
Does someone have a wiring diagramme for this vehicle?
Does anyone know why the heater motor might just up and quit? (It may only be coincidental that the motor quit when dog decided to eat the car.)
Can anyone give me a list of things to check from easiest to hardest to track the problem down?

It's winter in NZ at the moment and having warmth and the ability to de-mist the windscreen is pretty handy.

I'm a pretty good shade-tree mechanic and know my way around electrical circuits and have a digital multi-meter.

Thanks for your help!
 

·
Registered
Joined
·
73 Posts
Discussion Starter #2
Heater motor magically working again!

Well, went out to work on this, turned the key on, moved the slider over and voila - it works!

So, should I be preparing to repair some common intermittent fault here?
 
1 - 3 of 3 Posts
Top