Peugeot Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hi just bought a 1998 peugeot 406 2.1 diesal, it has been stood for about 2years when it was first started the engine management light was on, the car was then stoppped and started again and the em light went out and it ticked over great when we started it the next day the em light was back on and the car will now not take the full throttle and the engine is hunting, we have put a new fuel filter on and put some injector cleaner in but problem still there, has anyone any ideas?
 

·
Registered
Joined
·
239 Posts
its gone into limp home mode which is normal when you get a fault code its to save the engine from self destruction have you done any upgrades? is it a diesel and you over boosted it via a chip upgrade? the problem when you do this is the oil circulation the pressure cant deal with it unless you do other mods.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #6 ·
Hi just had the codes read but he did not tell us what they were he just said that he thinks it is inside the fuel injection pump where the fault lies.
We have not upgraded the engine in anyway, we have just bought the car and it has been stood for 2 years when we first started the car the engine the em light was on and it cut out, when we got it home via a tow truck we put some deisal in and it ran great with no em light on but the next day when we came to start it the em light was on again and it has gone into limp home mode.
If it is the fuel injection pump does anyone know where i can get one from or repaired cheaply
 
1 - 6 of 6 Posts
Top