Peugeot Forums banner

1 - 18 of 18 Posts

·
Registered
Joined
·
117 Posts
Discussion Starter #1
Hi mates,
my car 406 2.0 16v with petrol engine xu10 is not starting.
it suffered from loosing power especially when on high way the speed exceeding 100 km/hr, and finally it stalled on a traffic light and refusing to work again.
I have replaced Engine ICU, petrol relay, crank sensor and throttle position sensor but still not starting.
can anybody advise what to do?
thanks & regards
 

·
Registered
Joined
·
117 Posts
Discussion Starter #3
I'd like to ask one question to the folks here: what if put jumper to close the open contacts in the fuel double relay in order to energize the fuel pump and ignition coil ? do you think this will make the car run ? or I gonna damage the engine ECU ?
please reply
regards
 

·
Registered
Joined
·
117 Posts
Discussion Starter #5
yes the fuel pump is running for short time when putting ignition on
I don't know how to diagnose if it is recognizing the key or not
thanks for reply
 

·
Registered
Joined
·
15,377 Posts
if it beeps at you with door open and key off it is recognising key

pump running means relay probably fine
 

·
Registered
Joined
·
117 Posts
Discussion Starter #7
actually it is not buzzing when key on and door open, even before it was some time beebing and sometimes not beebing
 

·
Registered
Joined
·
15,377 Posts
Ok then im not 100% sure but on a right hand drive there is a plug under the drivers carpet that causes issues it is probably still there but could be under left front carpet it gets wet and rots away

lift carpet then under felt find a plug check all the wires in plug.
 

·
Registered
Joined
·
117 Posts
Discussion Starter #15
I see, then do I have to tear the carpet or it can be released from the edge? I remember I tried to remove it before in order to check this connector but I was not able to do this, and I did not want to tear the carpet.
 

·
Registered
Joined
·
117 Posts
Discussion Starter #17
Thanks a lot, you are soo kind :thumb:
I will check and let you know, hopefully this weekend, don't go away keep around for few day.
wish you a very pleasant night.
 

·
Registered
Joined
·
117 Posts
Discussion Starter #18
Dear reliable
today I removed floor carpet on both front sides, nothing found on the left, I found one wire loom on the right side but there is no connector, all are continues wires expect 2 wire joined in one wire by normal terminal connector.
what else I will have to do.
please advise
 
1 - 18 of 18 Posts
Top