Peugeot Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hi guys ive got a 4007 that start and cuts out within 20 secs.The faultcodes i have are P0201 p0202 p0203 p0204 which autodata says replace all injectors??Any the injectors have been checked and three replaced.Fuel filter changed HP pump checked,egr checked,Cam and crank sensors checked.Any help would be great thanks
 

·
Moderator
Joined
·
5,980 Posts
I would check wiring to injectors and all earth points and then have ECU checked

Sent from my SM-G965F using Tapatalk
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
HI thanks for the reply forgot that bit already do ecu check and also changed ecu, bsi unit and lock barrel.Wiring checked most sensor checked using oscilloscope.
 

·
Registered
Joined
·
64 Posts
Maybe not the best approach

Hi,
Sounds like you have fired the parts cannon trying to hit the fault, not the best way to fault find, so far 3 injectors,Fuel filter,High pressure pump, changed ecu, bsi. etc. expensive way to carry out a repair.

Firstly the 4 faults show that you have a problem with all 4 injectors, now it is not likely that they have all failed at the same time, so changing 3 was unlikely to fix the issue, I fully agree with the comment windy1603 made that this could be an earthing issue.
This earthing could be an earth from the ecu.

You say you have put an oscilloscope on various points, what is the signal to an injector, could you post this trace image if you have it?
The next question does it start and run well for 20 seconds every time?
I ask if it runs well for a reason is the idle smooth or jumpy?
Have you checked all the earths and rails to the ecu?

Also do you have any live data to share?


Cheers Tony
 
1 - 4 of 4 Posts
Top